kernel: update linux 3.7 to 3.7.7
authorGabor Juhos <juhosg@openwrt.org>
Tue, 12 Feb 2013 09:51:11 +0000 (09:51 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 12 Feb 2013 09:51:11 +0000 (09:51 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35571

18 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.7/102-ehci_hcd_ignore_oc.patch
target/linux/generic/patches-3.7/811-pci_disable_usb_common_quirks.patch
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.7/0123-USB-fix-roothub-for-IFXHCD.patch
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/geos/target.mk

index 5d402f029821ff9eb04b3d3e5fb2b7d91e79185c..58e911ae42dc703aefc83593586adce7f3946088 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.6)
-  LINUX_KERNEL_MD5SUM:=4c4d80619c713f83015fc6b1c6280891
+ifeq ($(LINUX_VERSION),3.7.7)
+  LINUX_KERNEL_MD5SUM:=bd37c2e05cb82331eb00da81773b2d85
 endif
 
 # disable the md5sum check for unknown kernel versions
index 5f31bc594384fe90d49161999b2ec49328f3c102..74b90d448a55a7cda277c64715753c046e92bea4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 4a9a15d326697ef6e24545f9da599294a4ff2597..1227df163f44ddeae11e2ed484d0c002c7d2e0e7 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 43165314ac503365c1e3aa1921aa2b8450a67860..206763d77247ad4350341369db64524a61cdf066 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 0a285f935d23d3ba073ecbbf5e2d6d6112a8a400..96d90f370b89fc4c4258a0018d12d5c898bf7d58 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index bf1815a2e1e6e35221c9d09017af5a3108e82981..dfcfc263840a8ed9da44731b792771b6ab2d927e 100644 (file)
@@ -20,7 +20,7 @@
                mask = PORT_CSC | PORT_PEC | PORT_OCC;
        else
                mask = PORT_CSC | PORT_PEC;
-@@ -804,7 +804,7 @@ static int ehci_hub_control (
+@@ -808,7 +808,7 @@ static int ehci_hub_control (
                if (temp & PORT_PEC)
                        status |= USB_PORT_STAT_C_ENABLE << 16;
  
index 1c90a5cfbe9117a305462d4ce096df1a5fb7dce8..da73f6719f353b53127d49a5d42d2111366ee069 100644 (file)
@@ -39,7 +39,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -973,3 +988,4 @@ static void __devinit quirk_usb_early_ha
+@@ -974,3 +989,4 @@ static void __devinit quirk_usb_early_ha
  }
  DECLARE_PCI_FIXUP_CLASS_FINAL(PCI_ANY_ID, PCI_ANY_ID,
                        PCI_CLASS_SERIAL_USB, 8, quirk_usb_early_handoff);
index a7241f0f19a1ac608d48a560aad182a735388dfd..650b90f70259a55169b022c54502a0bf9489960f 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index d4eae8ba440cea8298ebca4b596eb3b44c34cf61..2eb2317a05e61687c056dccf4a9ac13a7db13576 100644 (file)
@@ -9,7 +9,7 @@ Subject: [PATCH 123/123] USB: fix roothub for IFXHCD
 
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -3906,7 +3906,7 @@ hub_port_init (struct usb_hub *hub, stru
+@@ -3940,7 +3940,7 @@ hub_port_init (struct usb_hub *hub, stru
                udev->ttport = hdev->ttport;
        } else if (udev->speed != USB_SPEED_HIGH
                        && hdev->speed == USB_SPEED_HIGH) {
index 7d9d08e0ffb45001fe1fee79e0f84267cfc6bed0..efa17d986fb32df50c905ba68a5fd848d7c37f16 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 DEVICE_TYPE:=developerboard
 
index 552d972de5c57c1d01b6e05b88fc7b645dcb4f0e..d7023cb6fccab000a351670484120fbc255f97da 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 3950c6ddcc13eb7a747d1a84840c8d777d45fa8d..a7d4330c65f3d592bcb32e151104d2d3fc783988 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 871c5b01b5857e1bcf8bbc47afad3fe456ddef1b..b7dac46a3c0979ec67adc811363517a15f84209b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index a5879dd0ebd060882edeee90a0af61fcd58535a5..3cd2e2ae62646d711e3ea5a47bdbf2de1c4ad87d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 5d0a643703602456683c2be96c43a5077e0c2305..80719258b3ca25bf269937dabb0be5b64433db42 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 7044f109785e33e7fb6b8965976d0be1e3436cb1..c1672c29aacc706aa2c3801dfbc6aee3b5b4f6f4 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index f215751d69d43c05def0ea775aa0ac702df5726f..29787294ea00fb46295a17a824ee72e3e8a50b27 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 90ed8f3b4a650d021649b8eb446f5c5ca1ac7c03..d1f73070fdfa8915118de6ead644b4055b6ff636 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.6
+LINUX_VERSION:=3.7.7
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \