package/kernel: add package for the PCF2123 RTC driver
authorGabor Juhos <juhosg@openwrt.org>
Wed, 4 Jan 2012 21:16:21 +0000 (21:16 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 4 Jan 2012 21:16:21 +0000 (21:16 +0000)
SVN-Revision: 29664

package/kernel/modules/other.mk

index 266aa01cb84b9b7f18f4d94722285954b0d38d56..62bc4e8a0d5bb396b0b071b3b3748b6169cb7b3a 100644 (file)
@@ -765,6 +765,22 @@ endef
 $(eval $(call KernelPackage,rtc-pcf8563))
 
 
+define KernelPackage/rtc-pcf2123
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Philips PCF2123 RTC support
+  DEPENDS:=+kmod-rtc-core
+  KCONFIG:=CONFIG_RTC_DRV_PCF2123
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)
+endef
+
+define KernelPackage/rtc-pcf2123/description
+ Kernel module for Philips PCF2123 RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pcf2123))
+
+
 define KernelPackage/n810bm
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Nokia N810 battery management driver