kernel: remove the dummy kmod-rtc-core-* package, make all rtc drivers depend on...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 17 May 2012 15:28:13 +0000 (15:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 17 May 2012 15:28:13 +0000 (15:28 +0000)
SVN-Revision: 31778

package/kernel/modules/001-depends.mk
package/kernel/modules/other.mk

index aad29392306fd0000d66d4d0412053b3453bedf2..6c493018df2fd926d43c5442afb25da40e20c648 100644 (file)
@@ -33,7 +33,5 @@ endef
 
 
 define AddDepends/rtc
-  DEPENDS+= \
-    +(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-2.6 \
-    +!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-3.x
+  DEPENDS+= @RTC_SUPPORT
 endef
index 3cf132352e2e651f062711cd23127642929fae3b..ea0e91ffee491ac8a71bfdba2c3194c9736deb67 100644 (file)
@@ -736,34 +736,6 @@ endef
 
 $(eval $(call KernelPackage,pwm-gpio))
 
-define KernelPackage/rtc-core-2.6
-  SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
-  TITLE:=Real Time Clock class support
-  KCONFIG:=CONFIG_RTC_CLASS
-  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
-  AUTOLOAD:=$(call AutoLoad,29,rtc-core)
-endef
-
-define KernelPackage/rtc-core-2.6/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-2.6))
-
-define KernelPackage/rtc-core-3.x
-  SUBMENU:=$(OTHER_MENU)
-  DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
-  TITLE:=Real Time Clock class support
-  KCONFIG:=CONFIG_RTC_CLASS=y
-endef
-
-define KernelPackage/rtc-core-3.x/description
- Generic RTC class support.
-endef
-
-$(eval $(call KernelPackage,rtc-core-3.x))
-
 define KernelPackage/rtc-pcf8563
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Philips PCF8563/Epson RTC8564 RTC support