bcm2708: explicitly check for SUBTARGET instead of using the device SUBTARGETS variable
authorFelix Fietkau <nbd@nbd.name>
Wed, 18 May 2016 11:43:57 +0000 (13:43 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 20 May 2016 12:37:52 +0000 (14:37 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/brcm2708/image/Makefile

index 35a72958daa30dee484e361b89cc56580381f38b..af45cf47c6fb78021fa12648da551bddf2b5d6d1 100644 (file)
@@ -54,25 +54,28 @@ endef
 DEVICE_VARS += DEVICE_DTS
 
 define Device/rpi
-  SUBTARGETS := bcm2708
   DEVICE_TITLE := Raspberry Pi B/B+/CM
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
 endef
-TARGET_DEVICES += rpi
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi
+endif
 
 define Device/rpi-2
-  SUBTARGETS := bcm2709
   DEVICE_TITLE := Raspberry Pi 2 B
   DEVICE_DTS := bcm2709-rpi-2-b
 endef
-TARGET_DEVICES += rpi-2
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi-2
+endif
 
 define Device/rpi-3
-  SUBTARGETS := bcm2710
   DEVICE_TITLE := Raspberry Pi 3 B
   DEVICE_DTS := bcm2710-rpi-3-b
   DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
 endef
-TARGET_DEVICES += rpi-3
+ifeq ($(SUBTARGET),bcm2708)
+  TARGET_DEVICES += rpi-3
+endif
 
 $(eval $(call BuildImage))