tools: fix stat symlink if destination already exists
authorFelix Fietkau <nbd@openwrt.org>
Mon, 26 Mar 2012 10:07:50 +0000 (10:07 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 26 Mar 2012 10:07:50 +0000 (10:07 +0000)
SVN-Revision: 31072

tools/Makefile

index 48cfbbcc5f93a613fe64fd1716ddb75af0d95a4c..87a2940d02156c343d628f40c3393dea2897a410 100644 (file)
@@ -102,6 +102,7 @@ endef
 endif
 
 $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
+       @rm -f $@
        @if stat --version > /dev/null 2>&1; then \
                ln -s `which stat` $@; \
        elif gstat --version > /dev/null 2>&1; then \