PXA can use EABI, too
authorImre Kaloz <kaloz@openwrt.org>
Sat, 26 Apr 2008 10:14:55 +0000 (10:14 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sat, 26 Apr 2008 10:14:55 +0000 (10:14 +0000)
SVN-Revision: 10949

target/linux/pxa/Makefile

index 7bf4c38f1cd3524e2c25dce72919c754b007dd26..d4d326f9a677a3bbd9d34cf2f956139d6bdfd4a6 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=pxa
-BOARDNAME:=PXA
+BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=jffs2 broken
 
 LINUX_VERSION:=2.6.21.7
@@ -16,7 +16,13 @@ LINUX_VERSION:=2.6.21.7
 include $(INCLUDE_DIR)/target.mk
 
 define Target/Description
-       Stub for boards based on intel PXA
+       Build images for PAX2xx systems, eg. Gumstix.
+endef
+
+define Kernel/Configure
+       $(call Kernel/Configure/Default)
+       $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+       $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
 endef
 
 $(eval $(call BuildTarget))