fixup machid workaround, generate uImage manually
authorImre Kaloz <kaloz@openwrt.org>
Mon, 16 Jun 2008 12:38:55 +0000 (12:38 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 16 Jun 2008 12:38:55 +0000 (12:38 +0000)
SVN-Revision: 11497

target/linux/orion/Makefile
target/linux/orion/image/Makefile

index f2293b8f1406faca7c90350ae2d1b4872d6e0ae1..8b18cccb17cafb1e16026e5b48597c6c0845cb91 100644 (file)
@@ -15,8 +15,6 @@ LINUX_VERSION:=2.6.26-rc6
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
-
 DEFAULT_PACKAGES += kmod-madwifi
 
 define Kernel/Configure
index 073317fecdf8bbba41064b3d7efa1f664fc3c2ae..a8c2fbafff8275a4523a2079244a988bc56956ec 100644 (file)
@@ -11,11 +11,14 @@ define Image/Prepare
 #
 # XXX - FIXME, we hardcode for the WRT350N v2 for now
 #
-       echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/uImage
-       cat $(LINUX_DIR)/arch/arm/boot/uImage >> $(KDIR)/uImage
+       echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/zImage
+       cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/zImage
 endef
 
 define Image/BuildKernel
+       $(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
+       -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
+       -d $(KDIR)/zImage $(KDIR)/uImage
        cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
 endef