base-files: unconditionally unlock the rootfs_data partition (#7437)
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 24 Jul 2010 15:47:15 +0000 (15:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 24 Jul 2010 15:47:15 +0000 (15:47 +0000)
SVN-Revision: 22377

package/base-files/Makefile
package/base-files/files/lib/preinit/40_mount_jffs2

index 24bbf188c31793622090da58552f2cebc4ca0ea9..137eb62a2fcd76f4768dfab70dafd5520c3aa442 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=50
+PKG_RELEASE:=51
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index cb743ea75cc9861f28ca6f25339a2992a8d5ac45..d2f05b02ce342adf3f63aa6b3dde870408f5dfa0 100644 (file)
@@ -5,6 +5,7 @@
 find_mount_jffs2() {
        mkdir -p /tmp/overlay
     mount "$(find_mtd_part rootfs_data)" /tmp/overlay -t jffs2
+    mtd -qq unlock rootfs_data
 }
 
 jffs2_not_mounted() {