kernel: mark kmod-thermal menuconfig symbol as hidden to avoid building it on targets...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 27 Sep 2013 20:44:11 +0000 (20:44 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 27 Sep 2013 20:44:11 +0000 (20:44 +0000)
Should fix build errors with Linux 3.3/3.6 targets, which use different
kconfig symbols

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 38238

package/kernel/linux/modules/other.mk

index cbce02bbf5d2b135edad8c276c92eb61b528bd7b..b3e268e79cf93453c7024c0f340f9cfb19db7741 100644 (file)
@@ -765,6 +765,7 @@ $(eval $(call KernelPackage,random-core))
 define KernelPackage/thermal
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Generic Thermal sysfs driver
+  HIDDEN:=1
   KCONFIG:= \
        CONFIG_THERMAL \
        CONFIG_THERMAL_DEFAULT_GOV_STEP_WISE=y \