build: store default/device packages in JSON
authorPaul Spooren <mail@aparcar.org>
Tue, 30 Jun 2020 11:02:43 +0000 (01:02 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 13 Jul 2020 20:24:30 +0000 (21:24 +0100)
With this commit the `profiles.json` contain both the target specific
`default_packages` as well as the device specific `device_packages` as a
array of strings.

This information is required for downstream projects like the various
web-based interactive firmware generators.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 263f7e5bbd119ebed1f514c16f659a2e2a2b132c)

include/image.mk
scripts/json_add_image_info.py
scripts/json_overview_image_info.py

index 15f4fe9d3b9473ca6a9a53a4bbff9d729a8fe809..a13f37f8863d754da6b510265691cc433582615b 100644 (file)
@@ -536,6 +536,7 @@ define Device/Build/image
        IMAGE_TYPE=$(word 1,$(subst ., ,$(2))) \
        IMAGE_PREFIX="$(IMAGE_PREFIX)" \
        DEVICE_TITLE="$(DEVICE_TITLE)" \
+       DEVICE_PACKAGES="$(DEVICE_PACKAGES)" \
        TARGET="$(BOARD)" \
        SUBTARGET="$(if $(SUBTARGET),$(SUBTARGET),generic)" \
        VERSION_NUMBER="$(VERSION_NUMBER)" \
index b4d2dd8d71097ad0c92a7b1bd415bc100caa0daa..d1599b514ac67db68fdd510074c509d6d0848e45 100755 (executable)
@@ -41,6 +41,7 @@ image_info = {
                     "sha256": image_hash,
                 }
             ],
+            "device_packages": getenv("DEVICE_PACKAGES").split(),
             "supported_devices": getenv("SUPPORTED_DEVICES").split(),
             "titles": get_titles(),
         }
index a1418e366d6f963aa5ad8c4458aed996207bfd89..59d69df314e9e2820cbf4b28aea1959a93577fa3 100755 (executable)
@@ -1,9 +1,10 @@
 #!/usr/bin/env python3
 
-import json
+from os import getenv, environ
 from pathlib import Path
-from os import getenv
+from subprocess import run
 from sys import argv
+import json
 
 if len(argv) != 2:
     print("JSON info files script requires ouput file as argument")
@@ -31,6 +32,21 @@ for json_file in work_dir.glob("*.json"):
                 image_info["profiles"][device_id]["images"][0]
             )
 
+
+output["default_packages"] = run(
+    [
+        "make",
+        "--no-print-directory",
+        "-C",
+        f"target/linux/{output['target'].split('/')[0]}",
+        "val.DEFAULT_PACKAGES",
+    ],
+    capture_output=True,
+    check=True,
+    env=environ.copy().update({"TOPDIR": Path().cwd()}),
+    text=True,
+).stdout.split()
+
 if output:
     output_path.write_text(json.dumps(output, sort_keys=True, separators=(",", ":")))
 else: