kernel: update linux 3.0 to 3.0.18
authorJonas Gorski <jogo@openwrt.org>
Tue, 31 Jan 2012 09:43:53 +0000 (09:43 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 31 Jan 2012 09:43:53 +0000 (09:43 +0000)
SVN-Revision: 29965

include/kernel-version.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
target/linux/brcm63xx/Makefile
target/linux/malta/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile

index e66653f0d2d106fea5009359716d71f36d314648..85bfe81af25405a8675bbf66affaec33a6b3732e 100644 (file)
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.17)
-  LINUX_KERNEL_MD5SUM:=fcdd6a945445336e4cd28b2d195f1fea
+ifeq ($(LINUX_VERSION),3.0.18)
+  LINUX_KERNEL_MD5SUM:=67252770d7009eabe8bac7c26e074f9d
 endif
 ifeq ($(LINUX_VERSION),3.1.9)
   LINUX_KERNEL_MD5SUM:=4e387a49cde20805955c905bc8c311e0
index 8f3362a870bc6f20d1b5f53b336faef986526a68..0212ee68061ab459c0ca8012948fcaabe64cd1f7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 4837fe740f56ccfdf100ce6d3b9cf35fef5370ec..0a329c00a37b43d37b061c84dc9128c07c0c89ef 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/drivers/ssb/driver_pcicore.c
 +++ b/drivers/ssb/driver_pcicore.c
-@@ -75,7 +75,7 @@ static u32 get_cfgspace_addr(struct ssb_
+@@ -74,7 +74,7 @@ static u32 get_cfgspace_addr(struct ssb_
        u32 tmp;
  
        /* We do only have one cardbus device behind the bridge. */
@@ -19,4 +19,4 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 +      if (pc->cardbusmode && (dev > 1))
                goto out;
  
-       /* Type 0 transaction */
+       if (bus == 0) {
index 77e0a39edfb4ffb9b8ab6d24c7ac0e1ae324a0b7..88c4561bf8e6216f03b99dda0d33431ec95b69e6 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 50e073148eb079baaeb84883f2ae7cdce6f3b479..6557a85a1a76baf297dcb47a9662d90a3c14d9de 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index f1da2a66bad5e4ff79b81afe84d81c2283279e6a..ed899a139d74397cc9649321dfbc4f953b73b5f0 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index abbefba784a9e035f55801ff3e02fe95d2161136..2efb13a8defeee3c50c081d24f6c07716ef30fe7 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 3d5789e0d780feb3f5cdf40bb01687ab92603ec3..ed5718764a3e446eeebad706cf5868ea12b95e80 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 9b980b0267b9ed97b080818b79e29fa9d5ef88b9..b720079b5d372395095ce5a4e890f6775eb0bb72 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a6c9dba0ffd34b0a6c3b534d7fe3315e3b2f50a..97bb311651444cbc45d57734e5d1176eec6e029e 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk