rpcd: update to git head
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 9 Sep 2013 14:35:15 +0000 (14:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 9 Sep 2013 14:35:15 +0000 (14:35 +0000)
- adds support for service triggering on config commit
- adds uci transaction support
- adds daemon reload support without loosing session data
- exports headers for use by external plugins
- drops LuCI2 in favor to an out of tree plugin

SVN-Revision: 37921

package/system/rpcd/Makefile
package/system/rpcd/files/rpcd.init

index 0decaa651f2c4db0b09e5efafeda7aabf9801a6b..e6bf3a979114fa9ffcc53d8427d3f317e01d66e7 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rpcd
-PKG_VERSION:=2013-09-02
+PKG_VERSION:=2013-09-09
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/rpcd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=11f37e28898b12bf53d8df6272fa28c48d79a96b
+PKG_SOURCE_VERSION:=22fbf13086653cba0c60d60ceb7baba2f33a034d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
 
@@ -26,6 +26,11 @@ PKG_BUILD_PARALLEL:=1
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_BUILD_DIR)/include/rpcd $(1)/usr/include/
+endef
+
 define Package/rpcd/default
   SECTION:=utils
   CATEGORY:=Base system
@@ -79,5 +84,4 @@ endef
 
 $(eval $(call BuildPackage,rpcd))
 $(eval $(call BuildPlugin,file,,Provides ubus calls for file and directory operations.))
-$(eval $(call BuildPlugin,luci2,,Provides LuCI2 specific backend calls.))
 $(eval $(call BuildPlugin,iwinfo,+libiwinfo,Provides ubus calls for accessing iwinfo data.))
index 2b8f04f848502498e17471dc5470f7c19340d373..2132f16fd33dd3475582d914e65d333f59a55e8a 100755 (executable)
@@ -12,3 +12,7 @@ start() {
 stop() {
        service_stop /sbin/rpcd
 }
+
+reload() {
+       service_reload /sbin/rpcd
+}