mac80211: include the kfifo backport in compat.ko if necessary (fixes libertas, rt2x00)
authorFelix Fietkau <nbd@openwrt.org>
Thu, 13 Jan 2011 23:28:22 +0000 (23:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 13 Jan 2011 23:28:22 +0000 (23:28 +0000)
SVN-Revision: 24978

package/mac80211/Makefile
package/mac80211/patches/040-include_kfifo.patch [new file with mode: 0644]

index 5317a098ebb370132f2fea0ecc350a4998bc3a4b..11564c5b05681fffff538e95b9998179df5b231d 100644 (file)
@@ -994,6 +994,10 @@ MAKE_OPTS:= \
        KLIB=$(TARGET_MODULES_DIR) \
        KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER)))
 
+ifeq ($(CONFIG_PACKAGE_kmod-libertas-sd)$(CONFIG_PACKAGE_kmod-libertas-usb)$(CONFIG_PACKAGE_kmod-rt2x00-lib),)
+  MAKE_OPTS += CONFIG_COMPAT_KFIFO=
+endif
+
 define Build/Prepare
        rm -rf $(PKG_BUILD_DIR)
        mkdir -p $(PKG_BUILD_DIR)
diff --git a/package/mac80211/patches/040-include_kfifo.patch b/package/mac80211/patches/040-include_kfifo.patch
new file mode 100644 (file)
index 0000000..3ea64b5
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/compat/Makefile
++++ b/compat/Makefile
+@@ -2,9 +2,9 @@ obj-m += compat.o
+ #compat-objs :=
+ obj-$(CONFIG_COMPAT_FIRMWARE_CLASS) += compat_firmware_class.o
+-obj-$(CONFIG_COMPAT_KFIFO) += kfifo.o
+ compat-y += main.o
++compat-$(CONFIG_COMPAT_KFIFO) += kfifo.o
+ # Compat kernel compatibility code
+ compat-$(CONFIG_COMPAT_KERNEL_14) += compat-2.6.14.o
+--- a/config.mk
++++ b/config.mk
+@@ -90,7 +90,7 @@ endif #CONFIG_FW_LOADER
+ endif #CONFIG_COMPAT_KERNEL_33
+ ifdef CONFIG_COMPAT_KERNEL_36
+-CONFIG_COMPAT_KFIFO=m
++CONFIG_COMPAT_KFIFO=y
+ endif #CONFIG_COMPAT_KERNEL_36