package/kernel: add package for the ath79 watchdog
authorGabor Juhos <juhosg@openwrt.org>
Thu, 8 Mar 2012 09:00:16 +0000 (09:00 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 8 Mar 2012 09:00:16 +0000 (09:00 +0000)
SVN-Revision: 30851

package/kernel/modules/other.mk

index de2639802e623516a916a998543357dadf8b0240..23d558c955b2690ffcbdc32bc31829437a533950 100644 (file)
@@ -703,6 +703,23 @@ endef
 
 $(eval $(call KernelPackage,wdt-scx200))
 
+
+define KernelPackage/wdt-ath79
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Atheros AR7XXX/AR9XXX watchdog timer
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_ATH79_WDT
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/ath79_wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,ath79_wdt)
+endef
+
+define KernelPackage/wdt-ath79/description
+  Kernel module for AR7XXX/AR9XXX watchdog timer.
+endef
+
+$(eval $(call KernelPackage,wdt-ath79))
+
+
 define KernelPackage/pwm
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PWM generic API