ramips: disable ill_acc driver by default
authorJohn Crispin <john@openwrt.org>
Sun, 14 Jul 2013 18:01:00 +0000 (18:01 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 14 Jul 2013 18:01:00 +0000 (18:01 +0000)
The driver seems to be causoing boot rpoblems on some SoCs

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 37314

target/linux/ramips/mt7620a/config-3.9
target/linux/ramips/patches-3.9/0137-MIPS-ralink-add-illegal-access-driver.patch
target/linux/ramips/rt288x/config-3.9
target/linux/ramips/rt305x/config-3.9
target/linux/ramips/rt3883/config-3.9

index ea7d6bc11a2e27cd10f352d9e77556ab5153e34e..de16bf0d0487ade3b4a5b7cfd5812f239f1f6e09 100644 (file)
@@ -138,6 +138,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 CONFIG_RALINK_USBPHY=y
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set
index c82b7a97c2b5d9655659e18a01b8436027b512b9..e29a52db2c32816e2ca023e83448cb3697cc1843 100644 (file)
@@ -10,19 +10,23 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  2 files changed, 88 insertions(+), 1 deletion(-)
  create mode 100644 arch/mips/ralink/ill_acc.c
 
---- a/arch/mips/ralink/Makefile
-+++ b/arch/mips/ralink/Makefile
-@@ -6,7 +6,7 @@
- # Copyright (C) 2009-2011 Gabor Juhos <juhosg@openwrt.org>
- # Copyright (C) 2013 John Crispin <blogic@openwrt.org>
+Index: linux-3.9.10/arch/mips/ralink/Makefile
+===================================================================
+--- linux-3.9.10.orig/arch/mips/ralink/Makefile        2013-07-14 10:54:04.242545881 +0200
++++ linux-3.9.10/arch/mips/ralink/Makefile     2013-07-14 11:42:58.726615805 +0200
+@@ -8,6 +8,8 @@
  
--obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
-+obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o ill_acc.o
+ obj-y := prom.o of.o reset.o clk.o irq.o pinmux.o timer.o
  
++obj-$(CONFIG_RALINK_ILL_ACC) += ill_acc.o
++
  obj-$(CONFIG_SOC_RT288X) += rt288x.o
  obj-$(CONFIG_SOC_RT305X) += rt305x.o
---- /dev/null
-+++ b/arch/mips/ralink/ill_acc.c
+ obj-$(CONFIG_SOC_RT3883) += rt3883.o
+Index: linux-3.9.10/arch/mips/ralink/ill_acc.c
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ linux-3.9.10/arch/mips/ralink/ill_acc.c    2013-07-14 10:54:04.318545882 +0200
 @@ -0,0 +1,87 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify it
index 561f871d659a6d4ab9839e40f517880fe647117b..598c97231f2fa60fd8cff223699e4e271bc7ced1 100644 (file)
@@ -121,6 +121,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 # CONFIG_RALINK_USBPHY is not set
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set
index 72c6082437b246d66c2b8b5f85c2c448bef262ec..eb5232ba296671e1530151db856c8067cbc5905e 100644 (file)
@@ -123,6 +123,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 CONFIG_RALINK_USBPHY=y
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set
index 8bf49154bf67845a1d97f7a559e32767c3495b99..3db5077a3ca82470b51532a0fed5428005886663 100644 (file)
@@ -128,6 +128,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PHYLIB=y
 # CONFIG_PREEMPT_RCU is not set
 CONFIG_RALINK=y
+# CONFIG_RALINK_ILL_ACC is not set
 CONFIG_RALINK_USBPHY=y
 CONFIG_RALINK_WDT=y
 # CONFIG_RCU_STALL_COMMON is not set