ramips: add Kbuild patch for the rt288x pci code, and fix invalid header file paths
authorGabor Juhos <juhosg@openwrt.org>
Mon, 5 Oct 2009 09:06:10 +0000 (09:06 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 5 Oct 2009 09:06:10 +0000 (09:06 +0000)
SVN-Revision: 17860

target/linux/ramips/files/arch/mips/pci/ops-rt288x.c
target/linux/ramips/files/arch/mips/pci/pci-rt288x.c
target/linux/ramips/patches-2.6.30/102-rt288x-pci-driver-hook.patch [new file with mode: 0644]

index 44dadc9af1ba540dc1e7e372c052e7907b47c0bd..2bbe1f4e7dc37516f7e822e70403041ea1542102 100644 (file)
@@ -7,8 +7,9 @@
 #include <asm/io.h>
 #include <linux/init.h>
 #include <linux/mod_devicetable.h>
-#include <asm/mach-rt288x/rt288x.h>
-#include <asm/mach-rt288x/rt288x_pci.h>
+
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_pci.h>
 
 #ifdef CONFIG_PCI
 
index 8baefc3f255052fece5c796fb792b5e15b67478a..d4c65b6d04d4face91ba9136086ac89ad4ec46a3 100644 (file)
@@ -5,11 +5,12 @@
 #include <linux/version.h>
 #include <asm/pci.h>
 #include <asm/io.h>
-#include <asm/mach-rt288x/rt288x.h>
-#include <asm/mach-rt288x/rt288x_pci.h>
 #include <linux/init.h>
 #include <linux/mod_devicetable.h>
 
+#include <asm/mach-ralink/rt288x.h>
+#include <asm/mach-ralink/rt288x_pci.h>
+
 #ifdef CONFIG_PCI
 
 extern int pci_config_read(struct pci_bus *bus, unsigned int devfn, int where, int size, u32 *val);
diff --git a/target/linux/ramips/patches-2.6.30/102-rt288x-pci-driver-hook.patch b/target/linux/ramips/patches-2.6.30/102-rt288x-pci-driver-hook.patch
new file mode 100644 (file)
index 0000000..a1adbb5
--- /dev/null
@@ -0,0 +1,7 @@
+--- a/arch/mips/pci/Makefile
++++ b/arch/mips/pci/Makefile
+@@ -52,3 +52,4 @@
+ obj-$(CONFIG_ZAO_CAPCELLA)    += fixup-capcella.o
+ obj-$(CONFIG_WR_PPMC)         += fixup-wrppmc.o
+ obj-$(CONFIG_MIKROTIK_RB532)  += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
++obj-$(CONFIG_SOC_RT288X)      += pci-rt288x.o ops-rt288x.o