kernel: bump 4.14 to 4.14.200
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 7 Oct 2020 14:53:22 +0000 (16:53 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 12 Oct 2020 07:45:54 +0000 (09:45 +0200)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
20 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ar71xx/patches-4.14/411-mtd-cfi_cmdset_0002-force-word-write.patch
target/linux/ar71xx/patches-4.14/910-unaligned_access_hacks.patch
target/linux/ath79/patches-4.14/403-mtd_fix_cfi_cmdset_0002_status_check.patch
target/linux/ath79/patches-4.14/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.14/950-0202-drm-vc4-Fix-crash-if-we-have-to-unbind-HDMI.patch
target/linux/generic/backport-4.14/273-batman-adv-Convert-packet.h-to-uapi-header.patch
target/linux/generic/hack-4.14/702-phy_add_aneg_done_function.patch
target/linux/generic/hack-4.14/721-phy_packets.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/460-mtd-cfi_cmdset_0002-no-erase_suspend.patch
target/linux/generic/pending-4.14/461-mtd-cfi_cmdset_0002-add-buffer-write-cmd-timeout.patch
target/linux/generic/pending-4.14/655-increase_skb_pad.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
target/linux/layerscape/patches-4.14/819-sdhc-support-layerscape.patch
target/linux/mediatek/patches-4.14/0052-net-phy-add-FC.patch
target/linux/oxnas/patches-4.14/999-libata-hacks.patch
target/linux/ramips/patches-4.14/0037-mtd-cfi-cmdset-0002-force-word-write.patch

index 3ffcb3c59ceb7f7a3012bab4b8f439c5f5f272a0..d894d865a87afdece71d63b0c071b6692bc58826 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .199
+LINUX_VERSION-4.14 = .200
 
-LINUX_KERNEL_HASH-4.14.199 = 02f3432a262b3804745501f8c3c51d735133af48a39909df8b031d0b9653d4f9
+LINUX_KERNEL_HASH-4.14.200 = 5d404a0224a34b5379f1871cc46825487d557c2660459d2b5c3cd4871d699a38
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index faf4391a57c66fe38f88d58ca301c33fb2f6fe08..1a295fa11dd1e75a7cbdd8110a4c167a90418c64 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1641,7 +1641,7 @@ static int __xipram do_write_oneword(str
+@@ -1640,7 +1640,7 @@ static int __xipram do_write_oneword(str
                }
  
                if (chip_good(map, adr, datum))
@@ -9,7 +9,7 @@
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1658,6 +1658,8 @@ static int __xipram do_write_oneword(str
+@@ -1657,6 +1657,8 @@ static int __xipram do_write_oneword(str
                        goto retry;
                }
        }
@@ -18,7 +18,7 @@
        xip_enable(map, chip, adr);
   op_done:
        if (mode == FL_OTP_WRITE)
-@@ -2240,7 +2242,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2239,7 +2241,6 @@ static int cfi_amdstd_panic_write(struct
        return 0;
  }
  
@@ -26,7 +26,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -2308,7 +2309,7 @@ static int __xipram do_erase_chip(struct
+@@ -2307,7 +2308,7 @@ static int __xipram do_erase_chip(struct
                }
  
                if (chip_good(map, adr, map_word_ff(map)))
@@ -35,7 +35,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2332,6 +2333,7 @@ static int __xipram do_erase_chip(struct
+@@ -2331,6 +2332,7 @@ static int __xipram do_erase_chip(struct
                }
        }
  
@@ -43,7 +43,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        DISABLE_VPP(map);
-@@ -2405,7 +2407,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2404,7 +2406,7 @@ static int __xipram do_erase_oneblock(st
  
                if (chip_good(map, adr, map_word_ff(map))) {
                        xip_enable(map, chip, adr);
@@ -52,7 +52,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -2431,6 +2433,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2430,6 +2432,7 @@ static int __xipram do_erase_oneblock(st
                }
        }
  
index 9a367c2ab05533c2db2bce3d7c781bdc03afd9aa..0f7c4d68ed91a688a03629fe8b4690119d15ebcd 100644 (file)
@@ -35,7 +35,7 @@
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1800,6 +1804,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1799,6 +1803,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -43,7 +43,7 @@
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1932,7 +1937,6 @@ static int __xipram do_write_buffer(stru
+@@ -1931,7 +1936,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -51,7 +51,7 @@
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -2007,6 +2011,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2006,6 +2010,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }
index c5e201b371e047cc6ed910a95eb286bef367ad8d..1e9ec3d628b6e07a0bb8f2f6e287424b4e90432b 100644 (file)
        for (p = *head; p; p = p->next) {
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -464,7 +464,7 @@ static struct neighbour *ipv4_neigh_look
+@@ -465,7 +465,7 @@ static struct neighbour *ipv4_neigh_look
        else if (skb)
                pkey = &ip_hdr(skb)->daddr;
  
index faf4391a57c66fe38f88d58ca301c33fb2f6fe08..1a295fa11dd1e75a7cbdd8110a4c167a90418c64 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1641,7 +1641,7 @@ static int __xipram do_write_oneword(str
+@@ -1640,7 +1640,7 @@ static int __xipram do_write_oneword(str
                }
  
                if (chip_good(map, adr, datum))
@@ -9,7 +9,7 @@
  
                /* Latency issues. Drop the lock, wait a while and retry */
                UDELAY(map, chip, adr, 1);
-@@ -1658,6 +1658,8 @@ static int __xipram do_write_oneword(str
+@@ -1657,6 +1657,8 @@ static int __xipram do_write_oneword(str
                        goto retry;
                }
        }
@@ -18,7 +18,7 @@
        xip_enable(map, chip, adr);
   op_done:
        if (mode == FL_OTP_WRITE)
-@@ -2240,7 +2242,6 @@ static int cfi_amdstd_panic_write(struct
+@@ -2239,7 +2241,6 @@ static int cfi_amdstd_panic_write(struct
        return 0;
  }
  
@@ -26,7 +26,7 @@
  /*
   * Handle devices with one erase region, that only implement
   * the chip erase command.
-@@ -2308,7 +2309,7 @@ static int __xipram do_erase_chip(struct
+@@ -2307,7 +2308,7 @@ static int __xipram do_erase_chip(struct
                }
  
                if (chip_good(map, adr, map_word_ff(map)))
@@ -35,7 +35,7 @@
  
                if (time_after(jiffies, timeo)) {
                        printk(KERN_WARNING "MTD %s(): software timeout\n",
-@@ -2332,6 +2333,7 @@ static int __xipram do_erase_chip(struct
+@@ -2331,6 +2332,7 @@ static int __xipram do_erase_chip(struct
                }
        }
  
@@ -43,7 +43,7 @@
        chip->state = FL_READY;
        xip_enable(map, chip, adr);
        DISABLE_VPP(map);
-@@ -2405,7 +2407,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2404,7 +2406,7 @@ static int __xipram do_erase_oneblock(st
  
                if (chip_good(map, adr, map_word_ff(map))) {
                        xip_enable(map, chip, adr);
@@ -52,7 +52,7 @@
                }
  
                if (time_after(jiffies, timeo)) {
-@@ -2431,6 +2433,7 @@ static int __xipram do_erase_oneblock(st
+@@ -2430,6 +2432,7 @@ static int __xipram do_erase_oneblock(st
                }
        }
  
index f3332ba5c262d20f6853eaa579f47b8cb047e778..d9cefe1dfa71b1227186cc0c88ac8cf2f93a408c 100644 (file)
        for (p = *head; p; p = p->next) {
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -464,7 +464,7 @@ static struct neighbour *ipv4_neigh_look
+@@ -465,7 +465,7 @@ static struct neighbour *ipv4_neigh_look
        else if (skb)
                pkey = &ip_hdr(skb)->daddr;
  
index fa4f93216c7f8c5fd6c72dd6040f4dc97f6326cd..cb35f11f5e9e0ec77091c1f7e6780c448133c31c 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
 
 --- a/drivers/gpu/drm/vc4/vc4_hdmi.c
 +++ b/drivers/gpu/drm/vc4/vc4_hdmi.c
-@@ -1130,7 +1130,7 @@ static int vc4_hdmi_audio_init(struct vc
+@@ -1131,7 +1131,7 @@ static int vc4_hdmi_audio_init(struct vc
         * snd_soc_card_get_drvdata() if needed.
         */
        snd_soc_card_set_drvdata(card, hdmi);
@@ -22,7 +22,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
        if (ret) {
                dev_err(dev, "Could not register sound card: %d\n", ret);
                goto unregister_codec;
-@@ -1147,13 +1147,16 @@ unregister_codec:
+@@ -1148,13 +1148,16 @@ unregister_codec:
  static void vc4_hdmi_audio_cleanup(struct vc4_hdmi *hdmi)
  {
        struct device *dev = &hdmi->pdev->dev;
index a9f744fd13fa6e2df71b18775c0a5b7d24515dbc..6d5e4e7c6e9e9dfb6f9f8064fae2f60734d4f969 100644 (file)
@@ -97,7 +97,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  #include "translation-table.h"
 --- a/net/batman-adv/bridge_loop_avoidance.c
 +++ b/net/batman-adv/bridge_loop_avoidance.c
-@@ -49,6 +49,7 @@
+@@ -50,6 +50,7 @@
  #include <net/genetlink.h>
  #include <net/netlink.h>
  #include <net/sock.h>
@@ -105,7 +105,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  #include <uapi/linux/batman_adv.h>
  
  #include "hard-interface.h"
-@@ -56,7 +57,6 @@
+@@ -57,7 +58,6 @@
  #include "log.h"
  #include "netlink.h"
  #include "originator.h"
index 5885c8fae6953b6d0a049f07e797107316d3f1bb..c45183a104689f131853331851741acc5c117a0f 100644 (file)
@@ -15,7 +15,7 @@
  
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1466,6 +1466,9 @@ int genphy_update_link(struct phy_device
+@@ -1467,6 +1467,9 @@ int genphy_update_link(struct phy_device
  {
        int status;
  
index e6e06554de10214701dc04db6e8ac8c6b25a7dc8..93d63534eb66ccbe3b67a1183b243076403b64ce 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2532,6 +2532,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2544,6 +2544,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -67,7 +67,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2663,16 +2667,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2675,16 +2679,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
index e0c043f78f05ffdc208afff9e16c67f59a829a2c..222533c42b4dd821237e9061aa9c5c1e2f4fc974 100644 (file)
@@ -393,7 +393,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/route.c
 +++ b/net/ipv4/route.c
-@@ -426,6 +426,9 @@ static struct pernet_operations ip_rt_pr
+@@ -427,6 +427,9 @@ static struct pernet_operations ip_rt_pr
  
  static int __init ip_rt_proc_init(void)
  {
index 41f9d31cb0a33c5869ac6e75cf49dab0505b001c..3d39d3731db86ae6cf5c67f03a5181529e2570fa 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -811,7 +811,7 @@ static int get_chip(struct map_info *map
+@@ -810,7 +810,7 @@ static int get_chip(struct map_info *map
                return 0;
  
        case FL_ERASING:
index 932f219cf2963053d67bdf7d31ebb6c19f9b37da..1b07791ecafd8adb9dee035aef68307152103f4d 100644 (file)
@@ -7,7 +7,7 @@ Signed-off-by: George Kashperko <george@znau.edu.ua>
  1 file changed, 1 insertion(+)
 --- a/drivers/mtd/chips/cfi_cmdset_0002.c
 +++ b/drivers/mtd/chips/cfi_cmdset_0002.c
-@@ -1839,6 +1839,7 @@ static int __xipram do_write_buffer(stru
+@@ -1838,6 +1838,7 @@ static int __xipram do_write_buffer(stru
  
        /* Write Buffer Load */
        map_write(map, CMD(0x25), cmd_adr);
index fa47fe62a80cde13e35017765c5d9c769f638c8c..bccce61083ccb0244c2076766c2e6ef179849335 100644 (file)
@@ -9,7 +9,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2496,7 +2496,7 @@ static inline int pskb_network_may_pull(
+@@ -2508,7 +2508,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 42e84c9a0a5abd16a8d61f53a8ac06784eba8d40..e3fd88f6b0627d6ab1df050cf5f1b44cdcb0b9d9 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5122,6 +5135,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5125,6 +5138,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -6023,6 +6039,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6028,6 +6044,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6044,6 +6063,12 @@ static void ata_host_release(struct devi
+@@ -6049,6 +6068,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6490,7 +6515,23 @@ int ata_host_register(struct ata_host *h
+@@ -6495,7 +6520,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
@@ -134,7 +134,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
  /*
   * Define if arch has non-standard setup.  This is a _PCI_ standard
-@@ -894,6 +897,12 @@ struct ata_port {
+@@ -895,6 +898,12 @@ struct ata_port {
  #ifdef CONFIG_ATA_ACPI
        struct ata_acpi_gtm     __acpi_init_gtm; /* use ata_acpi_init_gtm() */
  #endif
index e421e556cd298a9f0e00965c17588d0b022c3654..2dd5b176038bbc9e9c1282ee7f6badfc6736def4 100644 (file)
@@ -580,7 +580,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  void  __kfree_skb(struct sk_buff *skb);
  extern struct kmem_cache *skbuff_head_cache;
  
-@@ -3315,6 +3316,7 @@ static inline void skb_free_datagram_loc
+@@ -3328,6 +3329,7 @@ static inline void skb_free_datagram_loc
  }
  int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
  int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
index 02688c74cdca6712abc92aa96fcfca838ee4e4e7..cc2d72290f7c8c75bd9d54b47caf53804fcb98e9 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Yinbo Zhu <yinbo.zhu@nxp.com>
 
 --- a/drivers/mmc/core/mmc.c
 +++ b/drivers/mmc/core/mmc.c
-@@ -1174,6 +1174,9 @@ static int mmc_select_hs400(struct mmc_c
+@@ -1173,6 +1173,9 @@ static int mmc_select_hs400(struct mmc_c
                goto out_err;
  
        /* Switch card to DDR */
index 46427a1d031af6b7b5c6dc85d251e4cbe2c686fc..a2ce9dcd8457aae48bb18b323d500a354f28170f 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/drivers/net/phy/phy_device.c
 +++ b/drivers/net/phy/phy_device.c
-@@ -1948,7 +1948,7 @@ static struct phy_driver genphy_driver =
+@@ -1949,7 +1949,7 @@ static struct phy_driver genphy_driver =
        .config_init    = genphy_config_init,
        .features       = PHY_GBIT_FEATURES | SUPPORTED_MII |
                          SUPPORTED_AUI | SUPPORTED_FIBRE |
index 0fb79dfaa82d80a623fc2399626628b4bff70637..d5c425b877486879fd16662978a6b6a3ced48043 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5129,6 +5137,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5132,6 +5140,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -5174,6 +5185,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5177,6 +5188,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
@@ -36,8 +36,8 @@
  
 --- a/include/linux/libata.h
 +++ b/include/linux/libata.h
-@@ -923,6 +923,8 @@ struct ata_port_operations {
-       void (*qc_prep)(struct ata_queued_cmd *qc);
+@@ -924,6 +924,8 @@ struct ata_port_operations {
+       enum ata_completion_errors (*qc_prep)(struct ata_queued_cmd *qc);
        unsigned int (*qc_issue)(struct ata_queued_cmd *qc);
        bool (*qc_fill_rtf)(struct ata_queued_cmd *qc);
 +      int (*qc_new)(struct ata_port *ap);
@@ -45,7 +45,7 @@
  
        /*
         * Configuration and exception handling
-@@ -1013,6 +1015,9 @@ struct ata_port_operations {
+@@ -1014,6 +1016,9 @@ struct ata_port_operations {
        void (*phy_reset)(struct ata_port *ap);
        void (*eng_timeout)(struct ata_port *ap);
  
index 39717bbad48e4654c6168640c6deeac1217cf56b..4f44aed3abc24ba6afada858831bd6e751ef7ee6 100644 (file)
@@ -44,7 +44,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  
  /* Atmel chips don't use the same PRI format as AMD chips */
  static void fixup_convert_atmel_pri(struct mtd_info *mtd)
-@@ -1798,6 +1802,7 @@ static int cfi_amdstd_write_words(struct
+@@ -1797,6 +1801,7 @@ static int cfi_amdstd_write_words(struct
  /*
   * FIXME: interleaved mode not tested, and probably not supported!
   */
@@ -52,7 +52,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  static int __xipram do_write_buffer(struct map_info *map, struct flchip *chip,
                                    unsigned long adr, const u_char *buf,
                                    int len)
-@@ -1930,7 +1935,6 @@ static int __xipram do_write_buffer(stru
+@@ -1929,7 +1934,6 @@ static int __xipram do_write_buffer(stru
        return ret;
  }
  
@@ -60,7 +60,7 @@ Subject: [PATCH 37/53] mtd: cfi cmdset 0002 force word write
  static int cfi_amdstd_write_buffers(struct mtd_info *mtd, loff_t to, size_t len,
                                    size_t *retlen, const u_char *buf)
  {
-@@ -2005,6 +2009,7 @@ static int cfi_amdstd_write_buffers(stru
+@@ -2004,6 +2008,7 @@ static int cfi_amdstd_write_buffers(stru
  
        return 0;
  }