Extend checks on build prerequisites for building OpenWRT core
authorBas Mevissen <abuse@basmevissen.nl>
Mon, 19 Apr 2021 23:08:19 +0000 (01:08 +0200)
committerBaptiste Jonglez <git@bitsofnetworks.org>
Sat, 8 May 2021 10:43:45 +0000 (12:43 +0200)
OpenWRT requires a number of Perl modules to be installed. It wasn't checking on all of them.
This patch adds checks for Perl FindBin, File::Copy, File::Compare and Thread::Queue modules.

Failing to install these, will have the build break at some point. By adding these to the
prereq-build.mk script, they are checked on forehand.

Tested on a Fedora 33 and 34 (beta) that was freshly installed. Fedora appears to
break up Perl modules into small packages that need to be installed for the build to succeed.

Signed-off-by: Bas Mevissen <abuse@basmevissen.nl>
include/prereq-build.mk

index 0375ef6861a4177eafa14f75cf1954da69225924..8adf0d03dd4f4637ceaa9d299c487908063b69d0 100644 (file)
@@ -65,11 +65,22 @@ $(eval $(call TestHostCommand,perl-data-dumper, \
        Please install the Perl Data::Dumper module, \
        perl -MData::Dumper -e 1))
 
+$(eval $(call TestHostCommand,perl-findbin, \
+       Please install the Perl FindBin module, \
+       perl -MFindBin -e 1))
+
+$(eval $(call TestHostCommand,perl-file-copy, \
+       Please install the Perl File::Copy module, \
+       perl -MFile::Copy -e 1))
+
+$(eval $(call TestHostCommand,perl-file-compare, \
+       Please install the Perl File::Compare module, \
+       perl -MFile::Compare -e 1))
+
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
        perl -MThread::Queue -e 1))
 
-
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \
        gnutar --version 2>&1 | grep GNU, \