[package] ppp: enable multilink support (#4837)
[openwrt/svn-archive/archive.git] / include / kernel-version.mk
index ad94c8e00b81e750add897ce1e968eb3560cdaba..5f05cf86296ec1ade7d2a645a4cd9dc6ec193f59 100644 (file)
@@ -1,32 +1,24 @@
 # Use the default kernel version if the Makefile doesn't override it
 
 ifeq ($(KERNEL),2.4)
-  LINUX_VERSION?=2.4.37.5
-else
-  LINUX_VERSION?=2.6.21.7
+  LINUX_VERSION?=2.4.37.9
 endif
 LINUX_RELEASE?=1
 
-ifeq ($(LINUX_VERSION),2.4.37.5)
-  LINUX_KERNEL_MD5SUM:=cb221187422acaf6c63a40c646e5e476
-endif
-ifeq ($(LINUX_VERSION),2.6.21.7)
-  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
+ifeq ($(LINUX_VERSION),2.4.37.9)
+  LINUX_KERNEL_MD5SUM:=b85b8962840c13f17f944e7b1890f8f8
 endif
 ifeq ($(LINUX_VERSION),2.6.25.20)
   LINUX_KERNEL_MD5SUM:=0da698edccf03e2235abc2830a495114
 endif
-ifeq ($(LINUX_VERSION),2.6.27.35)
-  LINUX_KERNEL_MD5SUM:=a4fa9eb5ee4876522e8015ca7da3ae40
-endif
-ifeq ($(LINUX_VERSION),2.6.28.10)
-  LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
+ifeq ($(LINUX_VERSION),2.6.30.10)
+  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
 endif
-ifeq ($(LINUX_VERSION),2.6.30.9)
-  LINUX_KERNEL_MD5SUM:=5a4cd5543a9d7c1a819700b21be31ef1
+ifeq ($(LINUX_VERSION),2.6.31.12)
+  LINUX_KERNEL_MD5SUM:=517be354b81b780e2f4b2ad614d030de
 endif
-ifeq ($(LINUX_VERSION),2.6.31.5)
-  LINUX_KERNEL_MD5SUM:=926bff46d24e2f303e4ee92234e394d8
+ifeq ($(LINUX_VERSION),2.6.32.8)
+  LINUX_KERNEL_MD5SUM:=82023ede52f067fcc55c5e70b02e48ae
 endif
 
 # disable the md5sum check for unknown kernel versions