Make aiccu depend on ntpclient, install our configuration file (#1616)
[openwrt/svn-archive/archive.git] / ipv6 / aiccu / Makefile
index f9098e45af8b12780d61624c650379daa4d5a3bb..dff8ad6ab199520b5cc50c2cffeb0225c6b3ac78 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
-PKG_VERSION:=20070107
+PKG_VERSION:=20070115
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
-PKG_MD5SUM:=67a6d55ef2d6e88a3f17bcb5eec02c61
+PKG_MD5SUM:=c9bcc83644ed788e22a7c3f3d4021350
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +ntpclient
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
   URL:=http://www.sixxs.net/tools/aiccu/
 endef
@@ -45,7 +45,7 @@ define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(1)/etc/
+       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
 endef