Make aiccu depend on ntpclient, install our configuration file (#1616)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 6 May 2007 15:47:08 +0000 (15:47 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 6 May 2007 15:47:08 +0000 (15:47 +0000)
SVN-Revision: 7112

ipv6/aiccu/Makefile

index 2f22f507d8982f7b36dc14d7c20e2fdd15fe8218..dff8ad6ab199520b5cc50c2cffeb0225c6b3ac78 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/aiccu
   SECTION:=ipv6
   CATEGORY:=IPv6
-  DEPENDS:=+libpthread
+  DEPENDS:=+libpthread +ntpclient
   TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
   URL:=http://www.sixxs.net/tools/aiccu/
 endef
@@ -45,7 +45,7 @@ define Package/aiccu/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(1)/etc/
+       $(INSTALL_CONF) ./files/aiccu.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aiccu.init $(1)/etc/init.d/aiccu
 endef