[packages] php5: predefine target endianess (#4560)
[openwrt/svn-archive/archive.git] / lang / gst-python / Makefile
index c72b079be66f109627e04568fec112c23953a4a7..9d246d902494039d25ab255f927487409fc2d6c7 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -18,7 +17,7 @@ PKG_FIXUP:=libtool
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 
 TARGET_CFLAGS += $(FPIC) \
@@ -37,7 +36,7 @@ define Package/gst-python
   CATEGORY:=Languages
   TITLE:=python bindings for gstreamer
   URL:=http://gstreamer.freedesktop.org/
-  DEPENDS:=+gstreamer +gst-plugins-base +python-gobject
+  DEPENDS:=+gstreamer +gst-plugins-base +python-gobject +python-mini
 endef
 
 define Package/gst-python/description
@@ -56,7 +55,7 @@ define Build/InstallDev
 
        $(INSTALL_DIR) $(1)/usr/share/gst-python/0.10/defs
        $(INSTALL_DATA) \
-               $(IPKG_INSTALL_DIR)/usr/share/gst-python/0.10/defs/* \
+               $(PKG_INSTALL_DIR)/usr/share/gst-python/0.10/defs/* \
                $(1)/usr/share/gst-python/0.10/defs/
 endef