[package] make arpd depend on librt, refresh patches (#5816)
[openwrt/svn-archive/archive.git] / lang / numpy / Makefile
index 03fa91c003e675c482cc486d5ed6af28001c0165..550b47bdf23862258b649076b6e79f2afed39900 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ PKG_NAME:=numpy
 PKG_VERSION:=1.0.4
 PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.sourceforge.net/numpy/
+PKG_SOURCE_URL:=@SF/numpy
 PKG_MD5SUM:=8f011e9d7697da570efaac61c51725e0
 
 include $(INCLUDE_DIR)/package.mk
@@ -39,8 +39,6 @@ define Package/numpy/install
        cp -r $(PKG_INSTALL_DIR)/* $(1)
 endef
 
-$(eval $(call BuildPackage,numpy))
-
 define Require/python25-dev
 [ -e /usr/include/python2.5/pyconfig.h ]
 endef
@@ -48,3 +46,6 @@ endef
 $(eval $(call Require,python25-dev, \
        Please install Python 2.5 (including development headers and libraries) \
 ))
+
+$(eval $(call BuildPackage,numpy))
+