[package] make arpd depend on librt, refresh patches (#5816)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 20 Sep 2009 12:23:08 +0000 (12:23 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 20 Sep 2009 12:23:08 +0000 (12:23 +0000)
SVN-Revision: 17633

net/arpd/Makefile
net/arpd/patches/001-configure_no_bpf.patch
net/arpd/patches/002-function_string.patch
net/arpd/patches/003-pcap_and_arg.patch
net/arpd/patches/004-no_dnet_config_check.patch

index 88598fe22edf8338aa552bfd4c7df69d31145548..8cf73276282b993422fec7226fd407109ed86f98 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=arpd
 PKG_VERSION:=0.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MD5SUM:=e2911fa9de1b92ef50deda1489ae944d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/arpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libpcap +libdnet +libevent
+  DEPENDS:=+libpcap +libdnet +libevent +librt
   TITLE:=A daemon to fake ARP replies
   URL:=http://niels.xtdnet.nl/honeyd/
 endef
index fb8037807a187850fe907e9bf3aabcc069abc81f..7113b45d924ae430c682a45e123ae4b6cf25dc18 100644 (file)
@@ -1,6 +1,6 @@
---- arpd/configure.orig        Sun Feb  9 19:31:28 2003
-+++ arpd/configure     Thu Jul 21 16:05:16 2005
-@@ -2258,8 +2258,7 @@
+--- a/configure
++++ b/configure
+@@ -2258,8 +2258,7 @@ echo "${ECHO_T}$withval" >&6
          if cd $withval; then withval=`pwd`; cd $owd; fi
          PCAPINC="-I$withval -I$withval/bpf"
          PCAPLIB="-L$withval -lpcap"
index 452b810e91fe1256238473847d7e4295a86a37ad..c2a3b41f694f367169648403967db65be655734b 100644 (file)
@@ -1,6 +1,6 @@
---- arpd/arpd.c.orig   Sun Feb  9 05:20:40 2003
-+++ arpd/arpd.c        Thu Jul 21 17:05:40 2005
-@@ -265,7 +265,7 @@
+--- a/arpd.c
++++ b/arpd.c
+@@ -265,7 +265,7 @@ arpd_send(eth_t *eth, int op,
            spa->addr_ip, tha->addr_eth, tpa->addr_ip);
        
        if (op == ARP_OP_REQUEST) {
@@ -9,7 +9,7 @@
                    addr_ntoa(tpa), addr_ntoa(spa));
        } else if (op == ARP_OP_REPLY) {
                syslog(LOG_INFO, "arp reply %s is-at %s",
-@@ -282,7 +282,7 @@
+@@ -282,7 +282,7 @@ arpd_lookup(struct addr *addr)
        int error;
  
        if (addr_cmp(addr, &arpd_ifent.intf_addr) == 0) {
@@ -18,7 +18,7 @@
                    addr_ntoa(addr), addr_ntoa(&arpd_ifent.intf_link_addr));
                return (0);
        }
-@@ -291,10 +291,10 @@
+@@ -291,10 +291,10 @@ arpd_lookup(struct addr *addr)
        error = arp_get(arpd_arp, &arpent);
        
        if (error == -1) {
@@ -31,7 +31,7 @@
                    addr_ntoa(addr), addr_ntoa(&arpent.arp_ha));
        }
        return (error);
-@@ -423,7 +423,7 @@
+@@ -423,7 +423,7 @@ arpd_recv_cb(u_char *u, const struct pca
                if ((req = SPLAY_FIND(tree, &arpd_reqs, &tmp)) != NULL) {
                        addr_pack(&src.arp_ha, ADDR_TYPE_ETH, ETH_ADDR_BITS,
                            ethip->ar_sha, ETH_ADDR_LEN);
index 7750e2928c5ee8e27905c3b9324c04aeaecfcdf4..b7edc0f4aa09c60e1e25da1291af1a5e4e5ad950 100644 (file)
@@ -1,6 +1,6 @@
---- arpd/arpd.c        Sun Feb  9 05:20:40 2003
-+++ arpd/arpd.c.new    Mon Aug  1 00:50:40 2005
-@@ -70,7 +70,7 @@
+--- a/arpd.c
++++ b/arpd.c
+@@ -70,7 +70,7 @@ static int                    arpd_sig;
  static void
  usage(void)
  {
@@ -9,7 +9,7 @@
        exit(1);
  }
  
-@@ -182,7 +182,7 @@
+@@ -182,7 +182,7 @@ arpd_expandips(int naddresses, char **ad
  }
  
  static void
@@ -18,7 +18,7 @@
  {
        struct bpf_program fcode;
        char filter[1024], ebuf[PCAP_ERRBUF_SIZE], *dst;
-@@ -214,9 +214,13 @@
+@@ -214,9 +214,13 @@ arpd_init(char *dev, int naddresses, cha
                errx(1, "bad interface configuration: not IP or Ethernet");
        arpd_ifent.intf_addr.addr_bits = IP_ADDR_BITS;
        
@@ -34,7 +34,7 @@
        
        if ((arpd_pcap = pcap_open_live(dev, 128, 0, 500, ebuf)) == NULL)
                errx(1, "pcap_open_live: %s", ebuf);
-@@ -465,14 +469,14 @@
+@@ -465,14 +469,14 @@ main(int argc, char *argv[])
  {
        struct event recv_ev;
        extern int (*event_sigcb)(void);
@@ -51,7 +51,7 @@
                switch (c) {
                case 'd':
                        debug = 1;
-@@ -480,6 +484,9 @@
+@@ -480,6 +484,9 @@ main(int argc, char *argv[])
                case 'i':
                        dev = optarg;
                        break;
@@ -61,7 +61,7 @@
                default:
                        usage();
                        break;
-@@ -489,9 +496,9 @@
+@@ -489,9 +496,9 @@ main(int argc, char *argv[])
        argv += optind;
  
        if (argc == 0)
index ac876d3c5aaa4cd66fd6583859a889fd44a07bdb..c3ebc12d406573ecb43af56f1446741ba713b13c 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN arpd/configure arpd.new/configure
---- arpd/configure     2003-02-09 19:31:28.000000000 +0100
-+++ arpd.new/configure 2008-10-12 14:23:35.000000000 +0200
-@@ -2170,8 +2170,7 @@
+--- a/configure
++++ b/configure
+@@ -2170,8 +2170,7 @@ echo "${ECHO_T}$withval" >&6
          DNETLIB="`$withval/bin/dnet-config --libs`"
       else
          { { echo "$as_me:2172: error: dnet-config not found in $withval/bin" >&5