[packages] python-curl: fix build failure
[openwrt/svn-archive/archive.git] / lang / pysqlite / Makefile
index 1746bbf5de610a7414d2ed527a194023f56307e9..1c77bbc7d744cb1c95f46a0ff9ffd471d5dc7ed8 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -19,7 +18,7 @@ PKG_MD5SUM:=b4a185e936848370fcc1a5b17755b641
 PKG_BUILD_DEPENDS:=python
 
 include $(INCLUDE_DIR)/package.mk
--include $(if $(DUMP),,$(STAGING_DIR)/mk/python-package.mk)
+$(call include_mk, python-package.mk)
 
 define Package/python-sqlite
  SUBMENU:=Python
@@ -27,7 +26,7 @@ define Package/python-sqlite
  CATEGORY:=Languages
  TITLE:=SQLite database adapter for Python
  URL:=http://www.initd.org/tracker/pysqlite/wiki/pysqlite
- DEPENDS:=python-core +libsqlite3
+ DEPENDS:=+python-mini +libsqlite3
 endef
 
 define Package/python-sqlite/description