[packages] python-curl: fix build failure
authorNicolas Thill <nico@openwrt.org>
Sat, 10 Jul 2010 00:47:54 +0000 (00:47 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 10 Jul 2010 00:47:54 +0000 (00:47 +0000)
 * add a patch to prevent use of host static curl library

SVN-Revision: 22109

lang/python-curl/patches/001-no_static.patch [new file with mode: 0644]

diff --git a/lang/python-curl/patches/001-no_static.patch b/lang/python-curl/patches/001-no_static.patch
new file mode 100644 (file)
index 0000000..3aa7706
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/setup.py
++++ b/setup.py
+@@ -97,8 +97,7 @@ else:
+         else:
+             extra_compile_args.append(e)
+     libs = split_quoted(
+-        os.popen("'%s' --libs" % CURL_CONFIG).read()+\
+-        os.popen("'%s' --static-libs" % CURL_CONFIG).read())
++        os.popen("'%s' --libs" % CURL_CONFIG).read())
+     for e in libs:
+         if e[:2] == "-l":
+             libraries.append(e[2:])