Requirements cleanup
[openwrt/svn-archive/archive.git] / lang / ruby / Makefile
index 9bce84e81ec459ff5c0f38899c3ea5215e1cf168..db8069d29308eba46b3108e8d7e14d6e119766a5 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ruby
-PKG_VERSION:=1.8.5
+PKG_VERSION:=1.8.5-p12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/1.8/
-PKG_MD5SUM:=3fbb02294a8ca33d4684055adba5ed6f
+PKG_MD5SUM:=d7d12dd9124c9b7d55cdbbee313e3931
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -39,6 +39,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               SHELL="/bin/bash" \
                all install
 endef
 
@@ -50,5 +51,5 @@ endef
 $(eval $(call BuildPackage,ruby))
 
 $(eval $(call RequireCommand,/usr/bin/ruby, \
-        Ruby requires ruby installed on the host-system. \
+        $(PKG_NAME) requires ruby installed on the host-system. \
 ))