Requirements cleanup
authorFlorian Fainelli <florian@openwrt.org>
Sat, 24 Mar 2007 23:01:10 +0000 (23:01 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 24 Mar 2007 23:01:10 +0000 (23:01 +0000)
SVN-Revision: 6691

lang/ruby/Makefile
libs/popt/Makefile
net/elinks/Makefile
sound/shell-fm/Makefile
utils/firmwarehotplug/Makefile
utils/lilo/Makefile

index 4aad8519a167344a84762b58f1b13b2979aeeb26..db8069d29308eba46b3108e8d7e14d6e119766a5 100644 (file)
@@ -51,5 +51,5 @@ endef
 $(eval $(call BuildPackage,ruby))
 
 $(eval $(call RequireCommand,/usr/bin/ruby, \
-        Ruby requires ruby installed on the host-system. \
+        $(PKG_NAME) requires ruby installed on the host-system. \
 ))
index d7c833100fa4981171ca0f98f4739cd91a46d79c..a021dfcba5595d6aac3f8dededd546b258eedf1b 100644 (file)
@@ -63,5 +63,5 @@ endef
 $(eval $(call BuildPackage,libpopt))
 
 $(eval $(call RequireCommand,xgettext, \
-       popt requires GNU gettext to build. \
+       $(PKG_NAME) requires GNU gettext to build. \
 ))
index b1e4970409e62cbb9a988e29d4084f8c69bba351..a0aad9c5a950cf7903773294bad766b0e013c1f4 100644 (file)
@@ -91,6 +91,6 @@ endef
 $(eval $(call BuildPackage,elinks))
 
 $(eval $(call RequireCommand,autoconf, \
-       elinks requires GNU autoconf. \
+       $(PKG_NAME) requires GNU autoconf. \
 ))
 
index 16085daa47d29eb3a64e4d1941e9a860688a8415..04b424c76b6587256a0fe940a517122f44d87013 100644 (file)
@@ -61,6 +61,6 @@ $(eval $(call BuildPackage,shell-fm))
 
 
 $(eval $(call RequireCommand,aclocal, \
-       shell-fm requires automake \
+       $(PKG_NAME) requires automake \
 ))
 
index 501151739800dc283435aa801604605f59fb320b..4bf8e71278b2140d37414df6eadb8a43e5af2b7e 100644 (file)
@@ -50,5 +50,5 @@ endef
 $(eval $(call BuildPackage,firmwarehotplug))
 
 $(eval $(call RequireCommand,sdcc, \
-        Please install the SDCC Cross Compiler (sdcc). \
+        $(PKG_NAME) requires the SDCC Cross Compiler (sdcc). \
 ))
index 1f31d59eeccba37be01c2089e1dc9837bd039dd1..c77e245fc91eb157a863220d3c96d9f46e17815d 100644 (file)
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/lilo
   SECTION:=base
   CATEGORY:=Boot Loaders
-  DEPENDS:=@LINUX_2_6_X86||LINUX_2_4_X86
+  DEPENDS:=@LINUX_2_6_X86
   TITLE:=lilo
   URL:=ftp://metalab.unc.edu/pub/Linux/system/boot/lilo/
 endef