Add opendchub
[openwrt/svn-archive/archive.git] / lang / sablevm-classpath / Makefile
index c2e0cfae4fc14b2877d6ef4d25e679c12e567bb3..2b1f291c646bf5fb7bc61c2a796c062235899402 100644 (file)
@@ -69,21 +69,21 @@ define Build/Compile
 endef
 
 define Package/libsablevm-classpath/install    
-       install -d -m0755 $(1)/usr/lib/sablevm-classpath
+       $(INSTALL_DIR) $(1)/usr/lib/sablevm-classpath
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/sablevm-classpath/libjava*.so $(1)/usr/lib/sablevm-classpath/
-       install -d -m0755 $(1)/usr/lib/security
+       $(INSTALL_DIR) $(1)/usr/lib/security
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/security/classpath.security $(1)/usr/lib/security/
 endef
 
 define Package/sablevm-classpath-full/install  
-       install -d -m0755 $(1)/usr/share/sablevm-classpath
+       $(INSTALL_DIR) $(1)/usr/share/sablevm-classpath
        $(CP) $(PKG_INSTALL_DIR)/usr/share/sablevm-classpath/{libclasspath,resources}.jar \
                $(1)/usr/share/sablevm-classpath/
 endef
        
 define Package/sablevm-classpath-mini/install  
-       install -d -m0755 $(1)/usr/share/sablevm-classpath
-       install -m0755 $(PKG_BUILD_DIR)/lib/mini.jar \
+       $(INSTALL_DIR) $(1)/usr/share/sablevm-classpath
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/mini.jar \
                $(1)/usr/share/sablevm-classpath/libclasspath.jar
 endef