Add opendchub
authorFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 19:11:52 +0000 (19:11 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 27 Feb 2007 19:11:52 +0000 (19:11 +0000)
SVN-Revision: 6403

net/opendchub/Makefile [new file with mode: 0644]

diff --git a/net/opendchub/Makefile b/net/opendchub/Makefile
new file mode 100644 (file)
index 0000000..776f91f
--- /dev/null
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=opendchub
+PKG_VERSION:=0.7.15
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/opendchub
+PKG_MD5SUM:=8f9ab5bb7f85730f4b1ce7cceb6aef96
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/opendchub
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libopenssl +libpthread
+  TITLE:=software for the Direct Connect network
+  DESCRIPTION:=\
+       Open DC hub is a Unix/Linux version of the hub software\\\
+       for the Direct Connect network
+  URL:=http://opendchub.sourceforge.net
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               --disable-perl \
+       )
+endef
+
+define Build/Compile   
+       $(call Build/Compile/Default,\
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install \
+       )
+endef
+
+define Package/opendchub/install       
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/opendchub $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,opendchub))