[packages] Require* calls must now be placed before BuildPackage calls
[openwrt/svn-archive/archive.git] / lang / sablevm-sdk / Makefile
index 6760a50fe41a61e970f8d95d3240e21d324fe56d..94174b11c00f566a615d33a8a10ab1d00a350fde 100644 (file)
@@ -1,10 +1,9 @@
 #
-# Copyright (C) 2006,2007 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -24,7 +23,7 @@ define Package/sablevm/Default
   CATEGORY:=Languages
   TITLE:=A Java Virtual Machine (JVM) implementation
   URL:=http://sablevm.org/
-  DEPENDS:=+libltdl +libpopt +libpthread +zlib
+  DEPENDS:=+libltdl +libpopt +libpthread +zlib @!TARGET_avr32
 endef
 
 define Package/sablevm/Default/description
@@ -85,7 +84,7 @@ define Build/Configure
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                EARLY_CONFIGURE= \
                EXTRA_CONFIGURE= \
@@ -104,7 +103,7 @@ endef
 
 define Package/sablevm/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/{java-,}sablevm $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{java-,}sablevm $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsablevm-*.so $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/sablevm-classpath
@@ -127,12 +126,12 @@ define Package/sablevm-mini/install
                $(1)/usr/share/sablevm/examples/
 endef
 
-$(eval $(call BuildPackage,sablevm))
-$(eval $(call BuildPackage,sablevm-mini))
-
 $(foreach command, jikes fastjar, \
   $(eval $(call RequireCommand,$(command), \
    $(PKG_NAME) requires $(command). \
   )) \
 )
 
+$(eval $(call BuildPackage,sablevm))
+$(eval $(call BuildPackage,sablevm-mini))
+