[packages] libaio: update to v0.3.107, use "make install"
[openwrt/svn-archive/archive.git] / libs / boost / Makefile
index 256857c1a11907e9a2723481300b3b48022ae576..d7ef978243a1e3797b28037d20528f5eb26e1fe0 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12228 2009-03-12 22:43:15Z mirko $
 
 # Dude, this "boost" is really one of the most crude stuff I ported yet.
 
@@ -40,9 +39,9 @@ LIBRARIES:= \
        serialization \
 
 define Build/Compile
-       (cd $(PKG_BUILD_DIR) ; \
-               echo "using gcc : : $(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gcc : <cflags>$(CFLAGS) <cxxflags>$(CXXFLAGS) <linkflags>$(LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
-               $(STAGING_DIR_HOST)/usr/bin/bjam \
+       ( cd $(PKG_BUILD_DIR) ; \
+               echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <cflags>$(CFLAGS) <cxxflags>$(CXXFLAGS) <linkflags>$(LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
+               bjam \
                        '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
                        --toolset=gcc \
                        $(foreach c, $(LIBRARIES), \