[packages] libaio: update to v0.3.107, use "make install"
authorNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 11:42:29 +0000 (11:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 5 Oct 2009 11:42:29 +0000 (11:42 +0000)
SVN-Revision: 17870

libs/libaio/Makefile
libs/libaio/patches/001-arches_from_debian_package_0.3.106-8.patch
libs/libaio/patches/002-avr32_support.patch

index 42f2c86b84cc838cacb12f188b84a68400bbde0f..d8cc4fd52ac4937a56e588bf8d360c463a7eb052 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libaio
-PKG_VERSION:=0.3.106
-PKG_RELEASE:=2
+PKG_VERSION:=0.3.107
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/liba/libaio/
-PKG_MD5SUM:=9480e31cce6506091080d59211089bd4
+PKG_MD5SUM:=db32c19c61ca937bcb1ba48da9180682
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,7 +29,6 @@ define Build/Configure
 endef
 
 LIBAIO_CFLAGS:=-nostdlib -nostartfiles -I. $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)
-LIBAIO_SOVER:=1.0.1
 
 TARGET_CFLAGS += $(FPIC)
 
@@ -41,22 +40,21 @@ define Build/Compile
                LD="$(TARGET_CROSS)ld" \
                CFLAGS="$(LIBAIO_CFLAGS)" \
                all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               prefix="$(PKG_INSTALL_DIR)/usr" \
+               install
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/src/libaio.h $(1)/usr/include/
-       mkdir -p $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libaio.{a,so*} $(1)/usr/lib/
-       ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so
-       ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so.1
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libaio.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaio.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libaio/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/libaio.so.* $(1)/usr/lib/
-       ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so
-       ln -sf libaio.so.$(LIBAIO_SOVER) $(1)/usr/lib/libaio.so.1
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libaio.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libaio))
index f4ca5ff11dd70d2df062fcbb0044a3d4a5ab47e7..d0a76130616d8efc1fa1d9b960fb94a80f35971b 100644 (file)
@@ -1,5 +1,5 @@
---- libaio-0.3.106.orig/src/syscall-m68k.h
-+++ libaio-0.3.106/src/syscall-m68k.h
+--- /dev/null
++++ b/src/syscall-m68k.h
 @@ -0,0 +1,78 @@
 +#define __NR_io_setup         241
 +#define __NR_io_destroy               242
@@ -79,8 +79,8 @@
 +return (type) __res; \
 +}
 +
---- libaio-0.3.106.orig/src/syscall-sparc.h
-+++ libaio-0.3.106/src/syscall-sparc.h
+--- /dev/null
++++ b/src/syscall-sparc.h
 @@ -0,0 +1,130 @@
 +/* $Id: unistd.h,v 1.74 2002/02/08 03:57:18 davem Exp $ */
 +
 +return -1; \
 +}
 +
---- libaio-0.3.106.orig/src/syscall.h
-+++ libaio-0.3.106/src/syscall.h
+--- a/src/syscall.h
++++ b/src/syscall.h
 @@ -22,6 +22,16 @@
  #include "syscall-s390.h"
  #elif defined(__alpha__)
  #else
  #error "add syscall-arch.h"
  #endif
---- libaio-0.3.106.orig/src/syscall-mips.h
-+++ libaio-0.3.106/src/syscall-mips.h
+--- /dev/null
++++ b/src/syscall-mips.h
 @@ -0,0 +1,223 @@
 +/*
 + * This file is subject to the terms and conditions of the GNU General Public
 +
 +#endif /* (_MIPS_SIM == _MIPS_SIM_NABI32) || (_MIPS_SIM == _MIPS_SIM_ABI64) */
 +
---- libaio-0.3.106.orig/src/libaio.h
-+++ libaio-0.3.106/src/libaio.h
-@@ -72,6 +72,40 @@
+--- a/src/libaio.h
++++ b/src/libaio.h
+@@ -73,6 +73,40 @@ typedef enum io_iocb_cmd {
  #define PADDED(x, y)  unsigned y; x
  #define PADDEDptr(x, y) unsigned y; x
  #define PADDEDul(x, y)        unsigned y; unsigned long x
  #else
  #error        endian?
  #endif
---- libaio-0.3.106.orig/src/syscall-parisc.h
-+++ libaio-0.3.106/src/syscall-parisc.h
+--- /dev/null
++++ b/src/syscall-parisc.h
 @@ -0,0 +1,146 @@
 +/*
 + * Linux system call numbers.
 +    return K_INLINE_SYSCALL(sname, 5, arg1, arg2, arg3, arg4, arg5);  \
 +}
 +
---- libaio-0.3.106.orig/src/syscall-arm.h
-+++ libaio-0.3.106/src/syscall-arm.h
+--- /dev/null
++++ b/src/syscall-arm.h
 @@ -0,0 +1,116 @@
 +/*
 + *  linux/include/asm-arm/unistd.h
index d94a87a2b1e5195c6823b323eba12597de0489e9..60f81950fbbe5705a74e467ec3409047afa55590 100644 (file)
@@ -1,7 +1,6 @@
-diff -Nur libaio-0.3.106/src/libaio.h libaio-0.3.106-avr32/src/libaio.h
---- libaio-0.3.106/src/libaio.h        2007-11-27 11:07:20.000000000 +0100
-+++ libaio-0.3.106-avr32/src/libaio.h  2007-06-21 15:26:26.000000000 +0200
-@@ -106,6 +106,10 @@
+--- a/src/libaio.h
++++ b/src/libaio.h
+@@ -107,6 +107,10 @@ typedef enum io_iocb_cmd {
  #  else
  #    error "neither mipseb nor mipsel?"
  #  endif
@@ -12,9 +11,8 @@ diff -Nur libaio-0.3.106/src/libaio.h libaio-0.3.106-avr32/src/libaio.h
  #else
  #error        endian?
  #endif
-diff -Nur libaio-0.3.106/src/syscall-avr32.h libaio-0.3.106-avr32/src/syscall-avr32.h
---- libaio-0.3.106/src/syscall-avr32.h 1970-01-01 01:00:00.000000000 +0100
-+++ libaio-0.3.106-avr32/src/syscall-avr32.h   2007-06-21 15:26:26.000000000 +0200
+--- /dev/null
++++ b/src/syscall-avr32.h
 @@ -0,0 +1,91 @@
 +/*
 + * Copyright (C) 2007 Atmel Corporation
@@ -107,9 +105,8 @@ diff -Nur libaio-0.3.106/src/syscall-avr32.h libaio-0.3.106-avr32/src/syscall-av
 +                           : "memory");                               \
 +      return (type) __res_r12;                                        \
 +}
-diff -Nur libaio-0.3.106/src/syscall.h libaio-0.3.106-avr32/src/syscall.h
---- libaio-0.3.106/src/syscall.h       2007-11-27 11:07:20.000000000 +0100
-+++ libaio-0.3.106-avr32/src/syscall.h 2007-06-21 15:26:26.000000000 +0200
+--- a/src/syscall.h
++++ b/src/syscall.h
 @@ -32,6 +32,8 @@
  #include "syscall-parisc.h"
  #elif defined(__mips__)