[packages] libaio: update to v0.3.107, use "make install"
[openwrt/svn-archive/archive.git] / libs / boost / Makefile
index 26886ba221cb028b9bc2197bc5e5030e3cabff54..d7ef978243a1e3797b28037d20528f5eb26e1fe0 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 12228 2009-03-12 22:43:15Z mirko $
 
 # Dude, this "boost" is really one of the most crude stuff I ported yet.
 
@@ -19,6 +18,8 @@ PKG_SOURCE_URL:=@SF/boost \
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 
+PKG_BUILD_DEPENDS:=boost-jam/host
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/boost
@@ -26,7 +27,6 @@ define Package/boost
   CATEGORY:=Libraries
   TITLE:=Boost provides free peer-reviewed portable C++ source libraries
   URL:=http://www.boost.org/
-  DEPENDS:=+boost-jam
 endef
 
 define Build/Configure
@@ -39,9 +39,9 @@ LIBRARIES:= \
        serialization \
 
 define Build/Compile
-       (cd $(PKG_BUILD_DIR) ; \
-               echo "using gcc : : $(TOOLCHAIN_DIR)/usr/bin/$(GNU_TARGET_NAME)-gcc : <cflags>$(CFLAGS) <cxxflags>$(CXXFLAGS) <linkflags>$(LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
-               $(STAGING_DIR_HOST)/usr/bin/bjam \
+       ( cd $(PKG_BUILD_DIR) ; \
+               echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <cflags>$(CFLAGS) <cxxflags>$(CXXFLAGS) <linkflags>$(LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
+               bjam \
                        '-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
                        --toolset=gcc \
                        $(foreach c, $(LIBRARIES), \