Revert previous changeset, as it could break libtool fixups
[openwrt/svn-archive/archive.git] / libs / libffi-sable / Makefile
index 0de76f766dc1726ce60549488dfd18ec7164740b..2d6e9c11f02ee06152da1b880f51f6dc978eab93 100644 (file)
@@ -15,10 +15,6 @@ PKG_RELEASE:=3
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://sablevm.org/download/snapshot/2005-01-21/
 PKG_MD5SUM:=0c32eaaea0269c5fbe156fcd0be3e5bd
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,14 +22,19 @@ define Package/libffi-sable
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=Foreign Function Interface library (for sablevm)
-  DESCRIPTION:=\
-       The libffi library provides a portable, high level programming \\\
-       interface to various calling conventions. This allows a programmer to \\\
-       call any function specified by a call interface description at run \\\
-       time.
+  DEPENDS:=@!TARGET_avr32
   URL:=http://sources.redhat.com/libffi/
 endef
 
+define Package/libffi-sable/description
+       The libffi library provides a portable, high level programming 
+       interface to various calling conventions. This allows a programmer to 
+       call any function specified by a call interface description at run 
+       time.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -55,12 +56,6 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libffi.{a,so*} $(1)/usr/lib/
 endef
 
-define Build/UninstallDev      
-       rm -rf \
-               $(STAGING_DIR)/usr/include/ffi{,target}.h \
-               $(STAGING_DIR)/usr/lib/libffi.{a,so*}
-endef
-
 define Package/libffi-sable/install    
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libffi.so.* $(1)/usr/lib/