Create /etc if not existig (#1722)
[openwrt/svn-archive/archive.git] / net / atftp / Makefile
index 0e45338f8b22e92ec3c0ba169a02e67e56c2bd50..0ca8a0df08209595f1796d853c1d9d0deef8f670 100644 (file)
@@ -1,3 +1,4 @@
+#
 # Copyright (C) 2006 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,34 +11,36 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=atftp
 PKG_VERSION:=0.7
 PKG_RELEASE:=1
-PKG_MD5SUM:=3b27365772d918050b2251d98a9c7c82
 
-PKG_SOURCE_URL:=ftp://ftp.mamalinux.com/pub/atftp/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://ftp.mamalinux.com/pub/atftp/
+PKG_MD5SUM:=3b27365772d918050b2251d98a9c7c82
 PKG_CAT:=zcat
+TAR_OPTIONS += || true
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+PKG_BUILD_DEPENDS:=libncurses libpcre libreadline
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/atftp
+define Package/atftp/Default
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libreadline +libpcre
-  MENU:=1
-  TITLE:=TFTP client
-  DESCRIPTION:=TFTP client
+  TITLE:=TFTP
   URL:=ftp://ftp.mamalinux.com/pub/atftp/
 endef
 
+define Package/atftp
+  $(call Package/atftp/Default)
+  DEPENDS:=+libreadline +libncurses
+  TITLE+= client
+endef
+
 define Package/atftpd
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=atftp +libreadline +libpcre
-  TITLE:=TFTP server
-  DESCRIPTION:=TFTP server
-  URL:=ftp://ftp.mamalinux.com/pub/atftp/
+  $(call Package/atftp/Default)
+  DEPENDS:=+libpcre +libpthread
+  TITLE+= server
 endef
 
 define Package/atftpd/postinst
@@ -51,24 +54,28 @@ if [ $$? -ne 0 ]; then
 fi
 endef
 
+define Build/Configure
+       $(call Build/Configure/Default, \
+               --disable-libwrap \
+       )
+endef
+
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS) -Wall -D_REENTRANT" \
-               DESTDIR=$(PKG_INSTALL_DIR) \
-               all install
+               all
 endef
 
 define Package/atftp/install
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftp $(1)/usr/sbin/
 endef
 
 define Package/atftpd/install
-       install -m0755 -d $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/atftpd $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,atftp))