batman: cleanup to match advanced version
[openwrt/svn-archive/archive.git] / net / batman / Makefile
index 1bfd76c57aa46814e3ceb6dc39bd0359d418aa0d..9c9c41c14c0ae76f81919973960e6b456712d0b0 100644 (file)
@@ -14,7 +14,8 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)_sources
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_sources.tgz
-PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman/stable/sources/
+PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman/stable/sources/ \
+       http://downloads.open-mesh.net/batman/stable/sources/old/
 PKG_MD5SUM:=b00ad9603e32c85224d5b19f99126ddf
 PKG_CAT:=zcat
 
@@ -44,11 +45,10 @@ MAKE_FLAGS += \
        batmand install
 
 define Package/batman/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/batmand $(1)/usr/sbin/
-       $(CP) -a ./files/* $(1)/
-       chmod -R 755 $(1)/etc/init.d/batman
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/batmand $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/etc/init.d/batman $(1)/etc/init.d
+       $(INSTALL_DATA) ./files/etc/config/batman $(1)/etc/config
 endef
 
-
 $(eval $(call BuildPackage,batman))