xtables-addons: Update to 1.29. This fixes compile on linux-2.6.36. Also fix parallel...
[openwrt/svn-archive/archive.git] / net / bind / Makefile
index b5b2c5a08135d306836812eed9cb4c75ee0b5bca..2b5e4dd8eb72c4c4f69f672cbfe12ee47f89291d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.6.1-P1
-PKG_RELEASE:=1
+PKG_VERSION:=9.6.1-P2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=e6ce3b355c4e6bf5d66ef100f555da3f
+PKG_MD5SUM:=435bc2e26e470d46ddf2acb24abb6ea6
+
+PKG_FIXUP:=libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -79,19 +81,18 @@ endef
 export BUILD_CC="$(TARGET_CC)"
 
 CONFIGURE_ARGS += \
-               --enable-shared \
-               --enable-static \
-               --with-randomdev="/dev/urandom" \
-               --disable-threads \
-               --with-openssl="$(STAGING_DIR)/usr" \
-               --with-libtool \
-               --with-libxml2=no \
-               , \
-               BUILD_CC="$(TARGET_CC)" \
+       --enable-shared \
+       --enable-static \
+       --with-randomdev="/dev/urandom" \
+       --disable-threads \
+       --with-openssl="$(STAGING_DIR)/usr" \
+       --with-libtool \
+       --with-libxml2=no \
+
+CONFIGURE_VARS += \
+       BUILD_CC="$(TARGET_CC)" \
 
 define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
                BUILD_CC="$(HOSTCC)" \
                CC="$(HOSTCC)" \