dsl-qos-queue does not compile on 2.6.27, but it would not compile at all since it...
[openwrt/svn-archive/archive.git] / net / dsl-qos-queue / Makefile
index 35885b28e5a9abf0bd7af256be5ef51c39e89ade..c5ec54df53b1698d97e13404f6eddc58cdf9f4cc 100644 (file)
@@ -4,18 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dsl_qos_queue
 PKG_VERSION:=0.9.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=ccbe8d28c3508c67f669fe98532533be
 
-PKG_SOURCE_URL:=http://www.sonicspike.net/software/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=http://www.sonicspike.net/software/download/
+PKG_MD5SUM:=ccbe8d28c3508c67f669fe98532533be
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 
@@ -24,24 +23,26 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue
+  DEPENDS:=+iptables +kmod-ipt-queue @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27
   TITLE:=ADSL/ATM Bandwith management
-  DESCRIPTION:=ADSL/ATM Bandwith management
+endef
+
+define Build/Configure
 endef
 
 define Build/Compile
-$(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+       $(call Build/Compile/Default, \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               install_prefix="$(PKG_INSTALL_DIR)" \
-               all)
+               all \
+       )
 endef
 
 define Package/dsl-qos-queue/install   
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
-       install -m0755 $(PKG_BUILD_DIR)/dsl_qos_train $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/ipt_rules $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dsl_qos_train $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ipt_rules $(1)/usr/sbin
 endef
 
 $(eval $(call BuildPackage,dsl-qos-queue))