dsl-qos-queue does not compile on 2.6.27, but it would not compile at all since it...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 9 Dec 2008 23:21:47 +0000 (23:21 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 9 Dec 2008 23:21:47 +0000 (23:21 +0000)
SVN-Revision: 13570

net/dsl-qos-queue/Makefile

index 8ce8c15476d8742709bf5c67a657a13cce347592..c5ec54df53b1698d97e13404f6eddc58cdf9f4cc 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/dsl-qos-queue
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+iptables +kmod-ipt-queue @!LINUX_2_6_25 @!LINUX_2_6_26
+  DEPENDS:=+iptables +kmod-ipt-queue @!LINUX_2_6_25 @!LINUX_2_6_26 @!LINUX_2_6_27
   TITLE:=ADSL/ATM Bandwith management
 endef
 
@@ -32,7 +32,7 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include/libipq -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
                all \
        )