Convert aodv-uu to the KernelPackage template
[openwrt/svn-archive/archive.git] / net / knock / Makefile
index 0f9a04477682fd906db605f308df6650874cd12d..0433e7b365cf6297b84572ebc011d589b522d163 100644 (file)
@@ -79,9 +79,9 @@ define Package/knock/install
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/knock $(1)/usr/bin/
 endef
 
-define Package/kockd/install
+define Package/knockd/install
        $(INSTALL_DIR) $(1)/etc
-       install -m0600 $(PKG_INSTALL_DIR)/etc/knockd.conf $(1)/etc/
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/knockd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/knockd $(1)/usr/sbin/
 endef