Convert aodv-uu to the KernelPackage template
authorFlorian Fainelli <florian@openwrt.org>
Mon, 8 Jan 2007 09:44:35 +0000 (09:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 8 Jan 2007 09:44:35 +0000 (09:44 +0000)
SVN-Revision: 6027

net/aodv-uu/Makefile

index 773053b4a310a1860040f6494bc178d4eb1ad049..ea42a7f89b45da65d4e41bcd5a15ba60511df088 100644 (file)
@@ -40,14 +40,16 @@ define Package/aodv-uu
        This package contains the AODV userland daemon.
 endef
 
-define Package/kmod-aodv-uu
+define KernelPackage/aodv-uu
   $(call Package/aodv-uu/Default)
-  SECTION:=kernel
-  CATEGORY=Kernel drivers
   TITLE+= (kernel module)
   DESCRIPTION+=\\\
        \\\
        This package contains the AODV kernel module.
+  FILES:=$(PKG_BUILD_DIR)/lnx/kaodv.$(LINUX_KMOD_SUFFIX)
+  SUBMENU:=Network Support
+  AUTOLOAD:=$(call AutoLoad,80,$(shell cat ./files/aodv-uu.modules))
+  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
 endef
 
 ifeq ($(CONFIG_LINUX_2_6),y)
@@ -97,4 +99,4 @@ define Package/kmod-aodv-uu/install
 endef
 
 $(eval $(call BuildPackage,aodv-uu))
-$(eval $(call BuildPackage,kmod-aodv-uu))
+$(eval $(call KernelPackage,aodv-uu))