[net] Firewall: Moved firewalling related programs to Firewall submenu.
[openwrt/svn-archive/archive.git] / net / linuxigd / Makefile
index 17dd4f7f4d79dfdf8b6df3f5b47bce041a12de09..6fc5c153b0cc3a6ef403a6bcbe2e40be152ca9d9 100644 (file)
@@ -5,7 +5,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
@@ -16,9 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-igd
 PKG_MD5SUM:=929f5c4878c91d534613b7c7070215d9
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 PKG_BUILD_DEPENDS:=iptables libupnp
 
@@ -28,22 +24,23 @@ define Package/linuxigd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=UPnP daemon
-  DEPENDS:=+libupnp +libpthread
+  SUBMENU:=Firewall
+  DEPENDS:=+libiptc +libupnp +libpthread @!LINUX_2_4
   URL:=http://linux-igd.sourceforge.net/
 endef
 
 define Package/linuxigd/description
-       It implements the UPnP Internet Gateway Device specification (IGD) 
-       and allows UPnP aware clients, such as MSN Messenger, Azureus or 
-       Miranda to work properly from behind a NAT firewall. 
-       
+       It implements the UPnP Internet Gateway Device specification (IGD)
+       and allows UPnP aware clients, such as MSN Messenger, Azureus or
+       Miranda to work properly from behind a NAT firewall.
+
        Please edit /etc/upnpd.conf before using upnpd!
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR)  \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -DIPTABLES_143 -Wl,-rpath-link=$(STAGING_DIR)/usr/lib" \
                BINDIR="/usr/sbin" \
                MANDIR="/usr/man" \
                HAVE_LIBIPTC=1 \