[packages] pptpd: various fixes
[openwrt/svn-archive/archive.git] / net / pptpd / Makefile
index 88273384ebf6ba0652c01a6eb144d9b0fcca16cd..6916eca685944b135a11ea287d460d761b2443f8 100644 (file)
@@ -1,56 +1,54 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
-PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
+PKG_VERSION:=1.3.4
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/poptop
-PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
-PKG_CAT:=zcat
+PKG_MD5SUM:=b38df9c431041922c997c1148bedf591
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/pptpd
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-ppp +kmod-gre
+  DEPENDS:=+kmod-ppp +kmod-gre +ppp
   TITLE:=PopTop pptp server
   URL:=http://www.poptop.org/
+  SUBMENU:=VPN
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-bcrelay \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-bcrelay \
+
+MAKE_FLAGS += \
+       COPTS="$(TARGET_CFLAGS)" \
+       INSTALL="install" \
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               COPTS="\$$$$(EXTRA_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               INSTALL="install" \
-               all install \
-       )
+define Package/pptpd/conffiles
+/etc/pptpd.conf
+/etc/ppp/options.pptpd
 endef
 
 define Package/pptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/sbin/bcrelay \
+               $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl \
+               $(PKG_INSTALL_DIR)/usr/sbin/pptpd \
+               $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/pptpd
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/pptpd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d