[packages] pptpd: various fixes
authorNicolas Thill <nico@openwrt.org>
Thu, 15 Apr 2010 08:09:46 +0000 (08:09 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 15 Apr 2010 08:09:46 +0000 (08:09 +0000)
 * enable bcrelay and package its binary (closes: #7150)
 * mark conffiles
 * add md5sum
 * use PKG_INSTALL
 * use $(CP) instead of $(INSTALL_BIN) for files installed by upstream 'make install'
 * cleanup

SVN-Revision: 20877

net/pptpd/Makefile

index 3e78e989e7600892a4e2f74946c63d074d617781..6916eca685944b135a11ea287d460d761b2443f8 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pptpd
 PKG_VERSION:=1.3.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/poptop
-#PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67 #1.3.0
+PKG_MD5SUM:=b38df9c431041922c997c1148bedf591
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,27 +28,27 @@ define Package/pptpd
   SUBMENU:=VPN
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-bcrelay \
-       )
-endef
+CONFIGURE_ARGS += \
+       --enable-bcrelay \
+
+MAKE_FLAGS += \
+       COPTS="$(TARGET_CFLAGS)" \
+       INSTALL="install" \
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               COPTS="$(TARGET_CFLAGS)" \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               INSTALL="install" \
-               all install \
-       )
+define Package/pptpd/conffiles
+/etc/pptpd.conf
+/etc/ppp/options.pptpd
 endef
 
 define Package/pptpd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/sbin/bcrelay \
+               $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl \
+               $(PKG_INSTALL_DIR)/usr/sbin/pptpd \
+               $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/lib/pptpd
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/pptpd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d