packages/scanlogd: change chroot to /var/run/scanlogd, use new service functions...
[openwrt/svn-archive/archive.git] / net / scanlogd / Makefile
index 1083ea8de24a241f880d33b20f6edd90265bb943..6b7305e6d76fd8233ae639cdf063bfc2f9ef3416 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scanlogd
 PKG_VERSION:=2.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openwall.com/scanlogd/ \
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/scanlogd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Firewall
   DEPENDS:=+libpcap +libnet0 +libnids
   TITLE:=Port scan detection tool
   URL:=http://www.openwall.com/scanlogd
@@ -37,8 +38,9 @@ define Package/scanlogd/description
 endef
 
 define Build/Configure 
-       $(SED) "s,/var/empty,/tmp/.scanlogd," $(PKG_BUILD_DIR)/params.h
-       $(SED) "s,#undef SCANLOGD_DEVICE,#define SCANLOGD_DEVICE \"all\"," $(PKG_BUILD_DIR)/params.h
+       $(SED) 's,^#define \(SCANLOGD_CHROOT\).*,#define \1 "/var/run/scanlogd",' \
+           -e 's,^#undef \(SCANLOGD_DEVICE\),#define \1 "all",' \
+           $(PKG_BUILD_DIR)/params.h
 endef
 
 define Build/Compile