[packages] tinc: update to 1.0.14 (#9384), thanks netztrip
[openwrt/svn-archive/archive.git] / net / tinc / Makefile
index efd6735d9789f64216ef038b2eddac594a3e78f7..9f9a2e41287145b6011b2fd131a418b115f05f35 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.13
+PKG_VERSION:=1.0.14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
-       http://ftp.yi.se/pub/tinc/ \
-       http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=86263994d38c750431efd17e9a91a248
+       http://ftp.yi.se/pub/tinc \
+       http://www.mirrors.wiretapped.net/security/network-security/tinc
+PKG_MD5SUM:=967dfafc4aa41a614c1d2739df8a8372
 
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-TARGET_CFLAGS+=-std=gnu99
-
 define Package/tinc
   SECTION:=net
   CATEGORY:=Network
@@ -37,13 +35,12 @@ define Package/tinc/description
   encryption to create a secure private network between hosts on the Internet.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --with-kernel="$(LINUX_DIR)" \
-               --with-zlib="$(STAGING_DIR)/usr" \
-               --with-lzo-include="$(STAGING_DIR)/usr/include/lzo" \
-       )
-endef
+TARGET_CFLAGS += -std=gnu99
+
+CONFIGURE_ARGS += \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-zlib="$(STAGING_DIR)/usr" \
+       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo"
 
 define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin