[packages] tinc: update to 1.0.14 (#9384), thanks netztrip
authorStephen Walker <stephendwalker@gmail.com>
Sun, 15 May 2011 08:29:45 +0000 (08:29 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 15 May 2011 08:29:45 +0000 (08:29 +0000)
SVN-Revision: 26896

net/tinc/Makefile

index 67501767fb4659fdf0da0a9d06226dd4765f0d02..9f9a2e41287145b6011b2fd131a418b115f05f35 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinc
-PKG_VERSION:=1.0.13
+PKG_VERSION:=1.0.14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.tinc-vpn.org/packages \
-       http://ftp.yi.se/pub/tinc/ \
-       http://www.mirrors.wiretapped.net/security/network-security/tinc/
-PKG_MD5SUM:=86263994d38c750431efd17e9a91a248
+       http://ftp.yi.se/pub/tinc \
+       http://www.mirrors.wiretapped.net/security/network-security/tinc
+PKG_MD5SUM:=967dfafc4aa41a614c1d2739df8a8372
 
 PKG_INSTALL:=1
 
@@ -40,12 +40,7 @@ TARGET_CFLAGS += -std=gnu99
 CONFIGURE_ARGS += \
        --with-kernel="$(LINUX_DIR)" \
        --with-zlib="$(STAGING_DIR)/usr" \
-       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo" \
-
-# XXX: checking for SHA1_version(), which is a variable, not a function,
-# fails on PowerPC, so just override it for now
-CONFIGURE_VARS += \
-       ac_cv_lib_crypto_SHA1_version="yes" \
+       --with-lzo-include="$(STAGING_DIR)/usr/include/lzo"
 
 define Package/tinc/install
        $(INSTALL_DIR) $(1)/usr/sbin