[packages] xinetd: update to 2.3.15 (CVE-2012-0862), use CONFIGURE_{ARGS,VARS} &...
[openwrt/svn-archive/archive.git] / net / xinetd / Makefile
index 754f793c7dba3df48e1c24612f79634448757442..c2bd6e069b08e15a2fcd98c63072ae623834956c 100644 (file)
@@ -1,23 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
-PKG_VERSION:=2.3.13
-PKG_RELEASE:=2
+PKG_VERSION:=2.3.15
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.xinetd.org/
-PKG_MD5SUM:=4295b5fe12350f09b5892b363348ac8b
+PKG_SOURCE_URL:=http://www.xinetd.org
+PKG_MD5SUM:=77358478fd58efa6366accae99b8b04c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,26 +26,32 @@ define Package/xinetd
   URL:=http://www.xinetd.org/
 endef
 
+define Package/xinetd/description
+       xinetd has access control mechanisms, extensive logging capabilities,
+       the ability to make services available based on time, can place limits
+       on the number of servers that can be started, and has deployable
+       defence mechanisms to protect against port scanners, among other
+       things.
+endef
+
 define Package/xinetd/conffiles
 /etc/xinetd.conf
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --without-libwrap \
-               --with-loadavg \
-       )
-endef
+TARGET_CFLAGS += -DNO_RPC
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               build install
-endef
+CONFIGURE_ARGS += \
+       --without-libwrap \
+       --with-loadavg
+
+CONFIGURE_VARS += \
+       ac_cv_header_rpc_pmap_clnt_h=no \
+       ac_cv_header_rpc_rpc_h=no \
+       ac_cv_header_rpc_rpcent_h=no
 
 define Package/xinetd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/xinetd $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/xinetd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/xinetd.conf $(1)/etc/xinetd.conf
        $(INSTALL_DIR) $(1)/etc/xinetd.d