enable netifd by default and add its config variable to PKG_CONFIG_DEPENDS in a few...
[openwrt/svn-archive/archive.git] / package / 6to4 / Makefile
index 14c9f2227d1e50b0793a6ba464ff9d1d2c876a65..95575cf6d04c6692bf2762ecc0cfc710753167b4 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=6
+PKG_VERSION:=8
 PKG_RELEASE:=1
 
 PKG_RELEASE:=1
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_netifd
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6to4
 include $(INCLUDE_DIR)/package.mk
 
 define Package/6to4
@@ -34,11 +36,20 @@ endef
 define Build/Configure
 endef
 
 define Build/Configure
 endef
 
-define Package/6to4/install
-       $(INSTALL_DIR) $(1)/lib/network
-       $(INSTALL_DATA) ./files/6to4.sh $(1)/lib/network/6to4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+  define Package/6to4/install
+       $(INSTALL_DIR) $(1)/lib/netifd/proto
+       $(INSTALL_BIN) ./files/6to4.sh $(1)/lib/netifd/proto/6to4.sh
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
        $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
        $(INSTALL_DATA) ./files/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
-endef
+  endef
+else
+  define Package/6to4/install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_DATA) ./files.old/6to4.sh $(1)/lib/network/6to4.sh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files.old/6to4.hotplug $(1)/etc/hotplug.d/iface/91-6to4
+  endef
+endif
 
 $(eval $(call BuildPackage,6to4))
 
 $(eval $(call BuildPackage,6to4))